Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm trying to play some Humble Indie Bundle (HIB) games, but I'm getting errors with Aquaria and Penumbra: Overture that are related to the libGL.so.1 file.

Aquaria gives this error on launch:

Message: SDL_GL_LoadLibrary Error: Failed loading libGL.so.1

And Penumbra: Overture gives this error on launch:

./penumbra.bin: error while loading shared libraries: libGL.so.1: cannot open shared object file: No such file or directory

I know that the file libGL.so.1 does exist (in /usr/lib/x86_64-linux-gnu/mesa/libGL.so.1). From past errors like this, I'm guessing that you need to symlink the library to another directory, but I can't figure out which one.

share|improve this question
add comment

3 Answers 3

up vote 3 down vote accepted

This is probably occurring because you are running the 64-bit version of Ubuntu and those particular HIB games only come in 32-bit flavor.

Try installing the 32-bit versions of the main OpenGL libraries (using multiarch):

sudo apt-get install libgl1-mesa-glx:i386 libgl1-mesa-dri:i386

On versions of Ubuntu earlier than 11.04 "Natty", create a 32-bit chroot instead.

share|improve this answer
add comment

You should copy or symlink it to

/usr/lib/libGL.so.1

However, please make sure, that your graphics driver is installed correctly, the libGL.so.1 belongs to the mesa driver. If you are using another driver (e.g. proprietary nvidia or ati drivers), you should however find the correct library for this driver. Usually reinstalling the driver should help or at least bring up a helping error message.

share|improve this answer
    
I have only an Intel integrated card, which is why I'm using the mesa driver (or whatever the default is, I haven't touched the graphics card configuration). In any case, I tried running the command ln -s /usr/lib/x86_64-linux-gnu/mesa/libGL.so.1 /usr/lib/libGL.s0.1, but it had no discernable effect. –  srunni Nov 19 '11 at 21:10
    
can you check whether opengl works at all (glxinfo and test with glxgears)? –  Michael K Nov 21 '11 at 7:12
    
Both glxinfo and glxgears work fine. –  srunni Nov 22 '11 at 13:00
    
okay, next please try the following: LD_LIBRARY_PATH="/usr/lib" ./penumbra.bin (it is one command!!) –  Michael K Nov 22 '11 at 13:02
add comment

I just had the same problem although I had the 32-bit libraries installed. Turned out /etc/alternatives/i386-linux-gnu_gl_conf was still pointing to an old fglrx install and I had to run

sudo update-alternatives --set i386-linux-gnu_gl_conf /usr/lib/i386-linux-gnu/mesa/ld.so.conf
sudo ldconfig

manually to select the mesa GL implementation.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.