Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I had Ubuntu 11.04 installed running gnome 2. I upgraded to 11.10 and everything went very smoothly. I installed GNOME Shell via:

sudo aptitude install gnome-shell

Logging into the Gnome session from Lightdm only launches Unity. I tried reinstalling gnome-shell and reconfiguring the gnome-session package to get it to rebuild the Lightdm .desktop files to no avail.

share|improve this question

closed as too localized by fossfreedom Mar 18 '12 at 22:26

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

    
If a full restart hasn't fixed then you first may want to determine if you're getting unity-3d or unity-2d. If not sure this command will tell you, ubuntu means 3d. Run without the quotes, " echo $DESKTOP_SESSION " –  doug Nov 15 '11 at 14:53
1  
It's very strange. When I run the gnome session the $DESKTOP_SESSION output gnome-shell even though unity is clearly running. Yes, I am running unity 3d when logging into Ubuntu session. –  dpendolino Nov 17 '11 at 14:17
    
This question appears to be abandoned, if you are experiencing a similar issue please ask a new question with details pertaining to your problem. If you feel this question is not abandoned, please flag the question explaining that. :) –  Ringtail Feb 26 '12 at 5:29

Browse other questions tagged or ask your own question.