Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I was following the instructions but got this:

$ sudo add-apt-repository ppa:freenx-team
Executing: gpg --ignore-time-conflict --no-options --no-default-keyring --secret-keyring /etc/apt/secring.gpg --trustdb-name /etc/apt/trustdb.gpg --keyring /etc/apt/trusted.gpg --primary-keyring /etc/apt/trusted.gpg --keyserver keyserver.ubuntu.com --recv F3A662B57D580D3A2E98E5152A8E3034D018A4CE
gpg: requesting key D018A4CE from hkp server keyserver.ubuntu.com
?: keyserver.ubuntu.com: Connection timed out
gpgkeys: HTTP fetch error 7: couldn't connect: Connection timed out
gpg: no valid OpenPGP data found.
gpg: Total number processed: 0

UPDATE

Apparntley this was a proxy issue. See https://bugs.launchpad.net/ubuntu/+source/software-properties/+bug/443404. I solved it by:

$ sudo http_proxy=http://myproxy:8080 add-apt-repository ppa:freenx-team

and continued following the instructions. Now I have another problem:

$ sudo /usr/lib/nx/nxsetup --install
------> It is recommended that you use the NoMachine key for
        easier setup. If you answer "y", FreeNX creates a custom
        KeyPair and expects you to setup your clients manually. 
        "N" is default and uses the NoMachine key for installation.

 Do you want to use your own custom KeyPair? [y/N] 
/usr/lib/nx/nxsetup: line 140: .: filename argument required
.: usage: . filename [arguments]
Setting up  ...mkdir: missing operand
Try `mkdir --help' for more information.
share|improve this question
    
@hhlp: I didn't get it. Should I just wait for a ppa? What can I do in the meanwhile? I really need my freenx server running. –  David B Oct 17 '10 at 14:27
    
@hhlp I tried, although I do not want that option. Anyway, I get the same error. –  David B Oct 17 '10 at 15:48
    
@hhlp not a single sole there... –  David B Oct 17 '10 at 16:00
add comment

1 Answer 1

you can do it yourself

Add this PPA to it's own list file

sudo bash -c "echo 'deb http://ppa.launchpad.net/freenx-team/ppa/ubuntu VERSION main deb-src http://ppa.launchpad.net/freenx-team/ppa/ubuntu VERSION main' >> /etc/apt/sources.list.d/freenx.list"

where VERSION can be: dapper, hardy, intrepid, lucid or maverick . More information can be found at FreeNX Team PPA.

Add the public key of FreeNX PPA run:

sudo apt-key adv --recv-keys --keyserver keyserver.ubuntu.com F3A662B57D580D3A2E98E5152A8E3034D018A4CE

Then Update Apt

sudo apt-get update

sudo apt-get install python-software-properties

sudo aptitude install Freenx

(note, as of Aug. 16 2010 the above command doesn't install a particular script file--appears to be missing from package. So after performing the above, download it from here. Next, cd to the directory to where the script was downloaded and un-packed, probably your downloads folder. Then, move the script into the proper directory: /usr/lib/nx/ with:

  > sudo mv nxsetup /usr/lib/nx/nxsetup

Finally, make sure you change the ownership of this file once you moved it so that it is owned by root:

  sudo chown root:root /usr/lib/nx/nxsetup

Now use nxsetup to install necessary files and create the special user "nx"

  sudo /usr/lib/nx/nxsetup --install 
share|improve this answer
    
same keyserver.ubuntu.com: Connection timed out –  David B Oct 17 '10 at 14:05
    
please see my update to the OP. –  David B Oct 17 '10 at 16:31
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.