Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

My laptop's hard drive heats up quite badly. The regular operating range hovers around 42-44 Centigrade. It gets even worse when the screen is locked with temperatures shooting up to 50C. The casing next to the track pad gets ridiculously hot and at this point I am really worried that continuous high temperatures is a hard drive failure waiting to happen.

I've searched and fiddled with hdparm spin-down options with no success. The other related option seems to be installing this thing called laptop-mode-tools. I'm not sure if this will do the trick since it seems to be about extending battery life whereas my problem occurs even with AC power on.

What are the options I have ? Will installing Laptop Mode Tools do anything good in this case ?

I am using a SATA 7200 rpm drive. Ubuntu version: Lucid Lynx.

share|improve this question
    
Mine hovers around 56° C., so 50° doesn't sound too bad :) Truthfully, laptop hard drives are designed to withstand higher temperatures. –  Nathan Osman Dec 11 '11 at 6:20
add comment

6 Answers 6

7200rpm is unusually fast for a laptop hard drive, and faster means hotter. There's no standard setting for making a hard disk spin slower, but maybe your disk has a nonstandard setting that the Windows driver uses. You could try hdparm -M 128, which tells the disk to be quieter (which implies slower and therefor less hot). There are plenty of disks where that makes no difference however.

share|improve this answer
3  
7200 is standard for a laptop HD, circa 2004. –  Dante Ashton Oct 17 '10 at 23:34
    
Thanks. I tried hdparm -M128, but no luck. –  suhridk Oct 18 '10 at 10:10
add comment

Maybe it's just a problem with the hard drive. Is it old? Did it work normally before? Try maybe a LiveCD and see if you still have the heat problem: if you do, then it's probably that your hard drive is in need of a check, maybe even a replacement.

share|improve this answer
1  
The hard drive was working normally with Windows Vista about a month ago which was when I made the switch to Ubuntu. I'll check if the problem persists with the LiveCD. –  suhridk Oct 17 '10 at 16:33
add comment

I know this might be kind of obvious, but have you tried dusting out your laptop? I had the exact same problem on my Acer Ferrari, and once I cleaned all the dust out it cooled down quite nicely.

share|improve this answer
    
Yeah, I vacuumed my laptop innards, but didn't help. I bought a laptop cooling pad as well - it keeps the cpu temp down, but does nothing for the hard-drive :( –  suhridk Oct 17 '10 at 15:49
add comment

One change you could make to decrease the amount of access to the disk, is to set the noatime option on fstab. This way the filesystem does not need to be written with the timestamp of the last access to the file.

I am assuming that for your purposes you do not need this timestamp, as for most desktop users use cases it is not used anywhere, just the modification time to determine when file was changed.

Example of entry in /etc/fstab with no atime:

UID=xxxxxxxx     /     ext3   errors=remount-ro,noatime 0 1
UID=yyyyyyyy     /home ext3   defaults,noatime          0 2
share|improve this answer
1  
Ubuntu defaults to relatime, which already gets rid of most atime updates (so noatime has little extra effect). –  Gilles Oct 17 '10 at 17:56
add comment

have you contacted the manufacturer of your computer just to know if they have any reports of possibles issues with those hard drives?

I used to work on a Customer Support line for a respectable computer company and I've seen those issues even on Windows too.

share|improve this answer
    
Thanks for the idea. I'm going to ask this on the Seagate forums. –  suhridk Oct 19 '10 at 6:20
    
You are welcome, let us know what they say –  Heiner Valverde Oct 28 '10 at 13:47
add comment

You'll find a disk utility tool under System -> Administration -> Disk Utility. Get it to look at your hard-drive, run SMART checks and see what it comes up with.

It could also be the case that your machine does not have enough RAM and is using the hard-drive to compensate. I don't know, I need more details :)

share|improve this answer
    
I ran the SMART checks and I see green lights everywhere. RAM is 4GB - the max for a 32 bit OS, so I dont think it can be an issue ? –  suhridk Oct 19 '10 at 6:19
    
Curious...the Disk Utility should report the tempreture (if your HD is equipped for it) –  Dante Ashton Oct 20 '10 at 18:32
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.