Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Depending on the application that is running when I open the dash it is sometimes nearly impossible to read the icons due to the transparency of the dash background. Is there a way to change the transparency?

share|improve this question
    

5 Answers 5

up vote 4 down vote accepted

If you choose the "Static blur" option the the Dash blur is set the 1st time you use the Dash per session.

So if you open the Dash over an appropriate background then that's what you'll get for the rest of the session, what you then open the Dash over won't matter

For a short time in 11.10 the "No Blur"; option used to provide a dark,solid dash, that's fallen by the wayside & no blur is pretty much worthless

Can be adjusted in the unity plugin > experimental settings in ccsm

If ccsm, (compizconfig-settings-manager) is installed & you wish to go directly to the unity settings then

Alt+F2, type in about:config and hit Enter.

It can also be set from terminal, 0=no blur, 1=static blur, 2=active blur (the default

Open a terminal and type the below command

gconftool-2 -s -t integer /apps/compiz-1/plugins/unityshell/screen0/options/dash_blur_experimental 1
share|improve this answer
    
Thanks a lot, but actually the option no blu gives a much better result in my opinion. –  dago Nov 14 '11 at 22:40
1  
Blurring is nothing to do with transparency, the question was about transparency –  Anwar Shah May 30 '12 at 4:26
    
The gconftool command does not work anymore in 14.04. Can you please update it? –  king_julien Jul 4 at 7:53
    
The gconftool command does not work anymore in 14.04. Can you please update it? – king_julien - No reason to do so. This question is 2.5 yr.s old & for 11.10. Maybe ask a new question (hint: Dash opacity is controlled by the opacity level of the 'background' color, ie. only can be adjusted when using a custom or black background color –  doug Jul 4 at 22:09

There is no way to manage the Dash transparency as yet, though you can change the blur. The Dash colour is affected by your wallpaper though, so you may need to change the wallpaper.

share|improve this answer
1  
Not the answer I was hoping for, but thanks. –  dago Nov 14 '11 at 20:22
    
The answer, though I was not hoping this. –  Anwar Shah May 23 '12 at 14:40
    
This has already been there for more than a year. Do we have any news about changing Dash transparency? –  lefterav Apr 12 '13 at 12:32
    
Unfortunately no change yet. –  RolandiXor Apr 13 '13 at 1:47

The original problem of not being able to read the file names on the dash still exists, but someone has apparently been working on the dash as now a white background seems to make the dash background darker so that the white letters show up better. The only problem now is that active portions of windows in the background will pop through the dash display and cover everything. This may seem to be a new question, but it still relates to the original problem of not being able to read the file names on the dash. It would seem that more work is required to allow dash transparency. It seems that transparency is the main problem and a totally opaque option should be available (like old fashioned window displays) for those people that have difficulty in remembering the names of hundreds of icons. Alternatively, have a black background surround the white text (and icon if you find icons to be important), but I have found that black text on a white background to be easier to read. So much so that I inverted the default colors for the terminal window so I can read the terminal text without a problem. The only other problem does not relate and that is the long time delays which cause me to use alternative methods of accessing programs whenever possible.

Overall, my personal opinion is that DASH is not ready for prime time. I look forward to any improvements that will improve readability and streamline the code to eliminate processing delays.

share|improve this answer

I found this one.

Just put in your ~/.xprofile (make new file if it doesn't exist):

export UNITY_LOW_GFX_MODE=1

It also disables other animations like pop-up blur etc. It works with Ubuntu 13.04, maybe also with previous versions.

Cheers

share|improve this answer

Not perfect solution, but works likewise.

In 13.10,

  • Install unity tweak tool.
  • change launcher background setting.
  • select dark custom color for background.

dash window background also would be affected by that setting.

unity tweak tool launcher setting

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.