Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Since Handbrake can't be installed in Oneiric, I decided to try and build it from source instead. The build is interrupted because it complains glib is not installed, so I thought I better install the glib development package. But I cant:

$ sudo aptitude install -V libglib2.0-dev
The following NEW packages will be installed:
  libglib2.0-dev{b} [2.30.0-0ubuntu4]  
0 packages upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
Need to get 1 775 kB of archives. After unpacking 8 831 kB will be used.
The following packages have unmet dependencies:
  libglib2.0-dev: Depends: libglib2.0-0 (= 2.30.0-0ubuntu4) but 2.31.0-0ubuntu1~oneiric1 is installed.
                  Depends: libglib2.0-bin (= 2.30.0-0ubuntu4) but 2.31.0-0ubuntu1~oneiric1 is installed.
Internal error: the solver Install(libglib2.0-bin 2.30.0-0ubuntu4 <libglib2.0-dev 2.30.0-0ubuntu4 -> {libglib2.0-bin 2.30.0-0ubuntu4 libglib2.0-bin 2.30.0-0ubuntu4}>) of a supposedly unresolved dependency is already installed in step 237

Aptitude the suggest a solution that involves removing basically all libraries, including libc.

How do I install the glib development package?


$ apt-cache policy libglib2.0-0
  Installed: 2.31.0-0ubuntu1~oneiric1
  Candidate: 2.31.0-0ubuntu1~oneiric1
  Version table:
 *** 2.31.0-0ubuntu1~oneiric1 0
        100 /var/lib/dpkg/status
     2.30.0-0ubuntu4 0
        500 oneiric/main amd64 Packages
share|improve this question
Can you add what PPAs you've added to your system to your question? Looks like you added something that has newer versions of libglib2.0 – Jorge Castro Nov 14 '11 at 17:43
Please post the output of apt-cache policy libglib2.0-0 – Florian Diesch Nov 14 '11 at 17:51
@FlorianDiesch Updated my question – Joachim Pileborg Nov 14 '11 at 18:27
up vote 2 down vote accepted

It appears you are/have used the "Gnome 3 PPA" which on 11/07 removed the Oneiric glib packages, why I didn't purse.

Sorta leaves you in a touchy situation, don't know if 11.10 has any plans to upgrade glib to 2.31

The packages are still available for manually downloading & installing, links here under "Builds" section, if so just grab the libglib2.0-dev_2.31.0-0ubuntu1~oneiric1 package

Your other option could be to use ppa-purge & return to 11.10 versions, not sure how well that would go.

share|improve this answer

Oneiric was the first release to enable "mutliarch" (more information in the release notes) on default amd64 installations, making it possible to install packages with a foreign architecture - specifically i386 (or 32-bit) packages on amd64 (64-bit). This is primarily being used currently for supporting 3rd-party software like Flash and Skype.

However, aptitude was not updated to support multiarch, so if you have any foreign architecture packages installed (which you would if you've installed Flash), aptitude tends to get confused by the state of t

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.