Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm running Ubuntu Jaunty on a plug computer which I only ever access via SSH.

I want to update Avahi on the device (without GUI) and the only way (that I know of) to get the very latest version is to build from source.

I've downloaded 0.6.30 from the Avahi site, but when I run ./configure I keep getting hassled for loads and loads of packages that I don't think I need (since I don't want the GUI).

At first I just installed whatever package it complained about and then ran ./configure again but now it's just getting silly!

Even running with ./configure --disable-qt3 --disable-qt4 --disable-gtk --disable-dbus --disable-mono --disable-monodoc --enable-core-docs I still get the error:

configure: error: Package requirements ( gtk+-3.0 ) were not met:

No package 'gtk+-3.0' found

Which is bizarre because I specified the --disable-gtk flag.

So what's going on here? And how can I build Avahi without all the unnecessary (optional) GUI components? There seems to be little -- if any -- documentation available on this.

share|improve this question

Solved it with flag --disable-gtk3

share|improve this answer
Jon would you accept you own answer as it does work for you. – Sneetsher Apr 3 '15 at 13:59

In case you do want to have gtk3, install it with:

sudo apt-get install libgtk-3-dev
share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.