Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm running Ubuntu Jaunty on a plug computer which I only ever access via SSH.

I want to update Avahi on the device (without GUI) and the only way (that I know of) to get the very latest version is to build from source.

I've downloaded 0.6.30 from the Avahi site, but when I run ./configure I keep getting hassled for loads and loads of packages that I don't think I need (since I don't want the GUI).

At first I just installed whatever package it complained about and then ran ./configure again but now it's just getting silly!

Even running with ./configure --disable-qt3 --disable-qt4 --disable-gtk --disable-dbus --disable-mono --disable-monodoc --enable-core-docs I still get the error:

configure: error: Package requirements ( gtk+-3.0 ) were not met:

No package 'gtk+-3.0' found

Which is bizarre because I specified the --disable-gtk flag.

So what's going on here? And how can I build Avahi without all the unnecessary (optional) GUI components? There seems to be little -- if any -- documentation available on this.

share|improve this question
add comment

2 Answers 2

Solved it with flag --disable-gtk3

share|improve this answer
add comment

In case you do want to have gtk3, install it with:

sudo apt-get install libgtk-3-dev
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.