Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I want to remove Videos and Music from the left side panel. But, I can't seem to find the option to do so. How do you do that?

enter image description here

share|improve this question
    
I was able to rename them in the side pane by just renaming each folder in the main pane. Highlight, press F2, rename. You might try making a symlink to your NAS folders and putting that in your Home folder, replacing the unneeded default folders. Right-click a destination folder, choose 'Make link', and drag the link into the home folder. Rename it Music or whatever, and replace the defaults. –  Tom Brossman Nov 4 '11 at 17:03
    
I'd bring something up at brainstorm.ubuntu.com. –  hexafraction Aug 27 '12 at 11:49
    
@ObsessiveFOSS Better bring it up to the GNOME devs. –  jokerdino Aug 27 '12 at 11:51
add comment

7 Answers

up vote 13 down vote accepted

Try this if instead of places you prefer a tree view of your folders placed on the left panel, use this command

gsettings set org.gnome.nautilus.window-state side-pane-view "tree"

To revert it back

gsettings set org.gnome.nautilus.window-state side-pane-view "places"

Or go to View > Sidebar while Nautilus is open.

share|improve this answer
1  
I get No such key 'side-pane-view' in 13.04 –  Vitaly Zdanevich Jun 2 '13 at 16:28
add comment

Open the file user-dirs.dirs in your ~/.config folder with your favorite text editor.

Comment out the line about the folder, which you do not want to be in the nautilus left pane. I commented about the Videos folder.

..........
..........
.........
XDG_DOCUMENTS_DIR="$HOME/Documents"
XDG_MUSIC_DIR="$HOME/Music"
XDG_PICTURES_DIR="$HOME/Pictures"
#XDG_VIDEOS_DIR="$HOME/Videos"

Then open a terminal, and run xdg-user-dirs-gtk-update, see the magic.

for 13.04 or later:

In Nautilus >= 3.6 this will not survive a logout/login or reboot. To overcome this we have to point our XDG directories to "$HOME" like e.g.:

XDG_VIDEOS_DIR="$HOME"
share|improve this answer
1  
This one should be marked as the correct answer. –  Rafael Vega Dec 18 '12 at 13:01
1  
Agreed, the best answer! TY very much. –  enapupe Apr 30 '13 at 14:15
    
I have been looking for this for a while. Great answer. Mark as correct @jokerdino –  SimplySimon Jun 4 '13 at 12:37
2  
...until you reboot! The way around this is to point the folder to $HOME this sticks :) –  SimplySimon Jun 4 '13 at 13:35
    
1.5 years later: found a more definitive solution (see below). –  Steve Jan 19 at 21:51
add comment

These directories are set by xdg-user-dirs.

Reading the documentation shows that you can disable a user directory by pointing it to your home directory. Use Ubuntu-Tweak or manually edit the file ~/.conf/user-dirs.dirs and point all the bookmarks you do not want to see to your home dir, and they will also disappear from the Nautilus side bar.

NOTE: I tried commenting out and removing the lines from ~/.conf/user-dirs.dirs as forestpiskie suggests, and that worked only until the next time I logged in. By setting them to the $HOME dir, the settings stuck.

share|improve this answer
add comment

Edit -

Dug into it a bit further - if you edit ~/.config/user-dirs.dir you can remove them from the panel and still have them as folders in your /home it seems.

enter image description here

share|improve this answer
1  
I have tried that. It doesn't work. –  jokerdino Nov 14 '11 at 13:49
    
Tried which - the old that I removed or this? –  Elfy Nov 14 '11 at 17:41
3  
That removes the special folder functions also from the system ie: downloads will not be selected as download folder anymore, pictures will not be the default folder when using image programs, I really dont advise you on doing that @jokerdino. –  Bruno Pereira Nov 14 '11 at 19:37
    
@brunopereira81 Are default directories the only thing this will change? Or might there be other, more drastic things? –  Kris Harper Nov 14 '11 at 19:49
1  
It will change more then just the default directories I think, thats why the warning, you can ofc set it back to how it was but that file is used to set up which directories you want to use for those functions, remove a directory, remove a function. –  Bruno Pereira Nov 14 '11 at 19:51
show 1 more comment

try going on Bookmarks in window menu, bookmarks > modify bookmarks (translate from italian ubuntu) and the remove the one that you don't want

otherwise Ctrl + D to access the menu

share|improve this answer
    
This doesn't work on Places anymore last I tried on Ubuntu 13.04. Editing the user-dirs.dirs as suggested above worked for me though. –  Cardin Aug 24 '13 at 4:26
add comment

I'm using Debian/XFCE and I can remove any bookmark from Nautilus by deleting the corresponding line the file ~/.gtk-bookmarks:

$ nano .gtk-bookmarks 

My ~/.gtk-bookmarks file now looks like:

file:///home/i/Documents
file:///home/i/Downloads
ftp://x1@example.com/ Remote FTP Server
sftp://root@192.168.1.111/var/www LAN webserver
etc...
share|improve this answer
add comment

Aha - the definitive answer, thanks to: http://jamesmcminn.com/2012/12/removing-entries-from-nautilus-3-6-places/

1) Comment out the unwanted bookmarks in ~/.config/user-dirs.dirs

2) Make or edit a ~/.config/user-dirs.dirs file and add the entry enabled=false.*

This solution persists over boot.


*...this could be done with a one-liner: echo "enabled=false" > ~/.config/user-dirs.conf

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.