Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am running Ubuntu 10.04 with ubuntu-resticted-extra installed. When I play .mkv with the default player, totem it causes the player to stop suddenly without any warning after a random amount of time!

Anybody else is having this problem? Is there any workaround other than installing vlc??

What I want to know is, Is it a bug in gstreamer? or I'm the only one facing this issue!

share|improve this question
2  
Try VLC media player. It plays almost every video format flawlessly. –  abhishek Nov 14 '11 at 12:20
add comment

3 Answers 3

Install gstreamer-ffmpeg. This should give you better playback with .mkv files. If it does not, then use another player (other than totem), such as VLC, or GNOME-Mplayer.

share|improve this answer
    
ubuntu-restricted-extra contains ffmpeg packages.ubuntu.com/lucid/ubuntu-restricted-extras... So, it will not help!!! –  Vineet Menon Nov 14 '11 at 12:31
    
@VineetMenon oh my mistake. I did an install for someone recently (but this was 11.10) and I had to install it manually. Try another player. –  RolandiXor Nov 14 '11 at 12:33
add comment

Its a BUG....in the meantime...

Install VLC

VLC is a free and open source cross-platform multimedia player and framework that plays most multimedia files as well as DVD, Audio CD, VCD, and various streaming protocols.

enter image description here

Open Synaptic application

Click on System -> Administration -> Synaptic Package Manager. In Settings -> Repositories, make sure you have an universe repository activated.

Search for vlc and install it, as well as vlc-plugin-pulse. You may also want to install mozilla-plugin-vlc.

If you are interested in streaming or transcoding, you should additionnally install libavcodec-extra-52 from a multiverse repository. Command line way

You need to check that a universe mirror is listed in your /etc/apt/sources.list file.

% sudo apt-get update
% sudo apt-get install vlc vlc-plugin-pulse mozilla-plugin-vlc
share|improve this answer
add comment

Try updating your Gstreamer.

Else you can try Mplayer http://www.mplayerhq.hu/design7/dload.html

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.