Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Running Ubuntu 11.10 in gnome classic, I just changed it to make gnome classic the auto login choice and now I cannot delete files, save files, or anything. I tried using the command:

sudo chown -R user:user /home/user

Only to get this response....

chown: cannot access `/home/user/.gvfs': Permission denied

Any help would be greatly appreciated. This is only my 3rd day ever using linux

share|improve this question
    
does it work, when you switch to superuser (sudo su) and then invoke the chmod command? –  Michael K Nov 14 '11 at 10:31
    
I tried typing "sudo su" instead of just "sudo" and it said that it was an invalid option. Is this what you meant? –  user33811 Nov 14 '11 at 10:38
    
Do you have an encrypted home folder? –  lgarzo Nov 14 '11 at 10:49
add comment

3 Answers 3

/home/user/.gvfs is the mount point for a virtual filesystem used by Gnome. It cannot be accessed by any other user than the session owner (not even root) while a Gnome session is active.

By default chown only prints error messages so if you don't get any other response from chown that means everything else worked fine.

If you still can't create or delete files in your home folder please post the output of the following commands:

ls -ld ~/
touch ~/this_is_just_a_test_file
rm -v ~/this_is_just_a_test_file
share|improve this answer
    
user@ubuntu:~$ ls -ld ~/ drwxr-xr-x 35 user user 4096 2011-11-14 15:02 /home/user/ user@ubuntu:~$ touch ~/this_is_just_a_test_file user@ubuntu:~$ rm -v ~/this_is_just_a_test_file removed `/home/user/this_is_just_a_test_file' –  user33811 Nov 14 '11 at 20:05
    
But I still cannot delete files off of my desktop that I put there, cannot save any files of any type except I guess for when I am in terminal? I don't understand –  user33811 Nov 14 '11 at 20:07
    
How do you try to save a file? Into which folder do you want to save it? –  Florian Diesch Nov 14 '11 at 21:06
    
I cannot save into any folder, ie. Desktop, Pictures, Videos, anything. It says that the file already exists and asks me to replace it, then if I try to replace it says permission denied. And I have never saved anything to any folder, so obviously the new files don't exist –  user33811 Nov 15 '11 at 0:23
add comment

I solved the problem by going to the properties of each folder in my Home folder, and changing the permissions to 'Create and Delete'. They were set to "no access'. So I guess it was a pretty simple solution, maybe there is an easier way? Thanks for everyone trying to help this noob.

share|improve this answer
add comment

Stupid question: did you change "user", using instead your user name?

Try: sudo chown -vR user /home/user

so you can see what happened.

ps my .gvfs is empty, and the .something are configuration files. You can delete it, if you didn't need the actual configuration (3rd day, I bet you didn't configure it ;):

sudo rm -fvr /home/user/.gvfs

share|improve this answer
    
@ Roland Taylor cannot remove `/home/user/.gvfs': Is a directory btw, my username is user lol –  user33811 Nov 15 '11 at 0:24
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.