Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I use ssh to connect to a remote machine where a file is.

Once the connection is established, if I run emacs the_file in the terminal, instead of launching my local Emacs, it opens an editor inside the terminal which is very modest...

Does anyone know how to open this file in a normal emacs session?

share|improve this question

1 Answer 1

up vote 4 down vote accepted

You could use tramp. Simply start your local emacs, open file (ctrl+x+f) and type the full address like this: /the.server.name:/the/path/to/the/file. So assuming the server is at example.com and the file at /home/me/test.txt, the address to type would be /example.com:/home/me/test.txt. This will open the file in the local emacs instance.

(Note that this does not require an additional manual ssh connection.)

Of course there is also the second option to use sshfs to mount the remote directory on a local address and open the local version.

share|improve this answer
    
Thanks for your comment... when I use ssh, I should write ssh a_name@server, and enter password... how should I enter this in Emacs? –  SoftTimur Nov 14 '11 at 15:49
    
got it... I should write /server:/... directly which normally includes a_name, and Emacs asks me the password... Thank you... –  SoftTimur Nov 14 '11 at 15:56
    
your welcome :-) –  xubuntix Nov 14 '11 at 15:59

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.