Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I installed gnome-shell from a 3rd party repository a while ago, but now it's in the official repository. How do I switch it and all it's dependencies to the official repository? I tried removing the other PPA and apt-get clean && apt-get update && apt-get upgrade, but it doesn't seem to detect any change. What do I do?

share|improve this question
add comment

3 Answers

up vote 1 down vote accepted

Use ppa-purge (not installed by default) to disable the PPA, that will automatically revert your packages to the official versions.

share|improve this answer
    
I ran it (sudo ppa-purge ppa:ricotz/testing), and it seemed to do something, but those packages still show up as under that PPA. Why? –  Jonah Nov 15 '11 at 1:56
    
Things were busting, I opted to reinstall. Everything's fixed now, but I'll bet if I hadn't messed with stuff before you replied, this would have fixed the problem. Marked as answer. –  Jonah Nov 15 '11 at 4:17
add comment

If you removed the other PPA from your sources and still don't get any update, that probably means that the version in the PPA is newer than the one in the official repository (even if you remove the PPA, the packages remain installed).

To make sure about that, you can use the apt-cache policy <package_name> command. In my case, it shows that the version available from the official repositories is 3.2.1-0ubuntu1. In your case it should show that that version is available, but you have installed a different one.

If you really want to have the same version as in the official repositories, you can downgrade the package. However, I wouldn't recommend that since my understanding is that the PPA version isn't causing any problem. Anyway, to downgrade the package, run the following command:

$ sudo apt-get install gnome-shell=3.2.1-0ubuntu1

Note: Some other packages might be installed/removed during the downgrade process if dependencies have changed for the two different versions of the package.

share|improve this answer
    
There's a very big tree of dependencies, and it failed when I tried to downgrade because of version conflicts. How can I downgrade all packages from that repository at the same time? –  Jonah Nov 15 '11 at 1:57
add comment

You can't switch packages to a different repository. If you don't need the PPA any more, remove it using the Software Sources interface (the commands you posted don't remove repositories).

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.