Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

When will this come for ubuntu ?

I am getting tired with my 11.10 dieing at little over 50 minutes of battery when at the most extreme powersaving plan.

share|improve this question

closed as off topic by James May 23 '12 at 17:47

Questions on Ask Ubuntu are expected to relate to Ubuntu within the scope defined by the community. Consider editing the question or leaving comments for improvement if you believe the question can be reworded to fit within the scope. Read more about reopening questions here.If this question can be reworded to fit the rules in the help center, please edit the question.

I am also waiting for this patch to be confirmed by Canonical. This battery/overheating issue has got to be solved – Mysterio Nov 13 '11 at 23:58
Excuse me if I'm missing something, but this doesn't seem like a dupe to me. The answer below seems to suggest otherwise to me. – Christopher Kyle Horton Nov 14 '11 at 7:16
Please don't just ask the same question again, the patch will be published as soon as enough people test it and the kernel team is confident that it works. – Jorge Castro Nov 15 '11 at 0:06
up vote 9 down vote accepted

Hopefully, the patch will make it into the 3.0.0-13 kernel update for 11.10. You can help testing.

PS: ...and if you don't want to wait, apply the relevant workarounds now. Note, some of the workarounds are only relevant for Intel GPUs.


To add the pcie_aspm option, open /etc/default/grub for editing with
gksudo gedit /etc/default/grub

find the the GRUB_CMDLINE_LINUX_DEFAULT="quiet splash" and change it to GRUB_CMDLINE_LINUX_DEFAULT="quiet splash pcie_aspm=force", save and exit.

Then run sudo update-grub.

You can also verify whether Active State Power Management is enabled or not with
dmesg | grep -i aspm

share|improve this answer
Please could you edit your answer to include the relevant workarounds like where and how to tweak the Grub config? – Mysterio Nov 14 '11 at 6:29
Done! Let me know how it goes. – mikewhatever Nov 14 '11 at 7:11
excellent answer +1 - just to say - this AU question and answer is still relevant to oneiric for intel users -… – fossfreedom Nov 14 '11 at 10:18
I'm sorry but this patch refers to the old patch Phoronix released the new patch i915.i915_rc6=1 which they claim as a fix and not a workaround. I can verify that this patch( your answer) does not solve the heating/power bug. Could you please edit your answer with the new patch PLEASE – Mysterio Nov 14 '11 at 14:42

A kernel update is due after the SRU tickets have tags changed from "testing-needed" to "testing-done" (after testing has actually been done.)

To find the SRU tickets try looking on this web page:

For 11.10 switching from 3.0.0-12.20 to 3.0.0-13.22 requires verification of the following tickets:

#737388 #782389 #794642 #816484 #851697 #854399 #854468 #855239
#857297 #860868 #862583 #865171 #866021 #868628 #870127 #872711
#872811 #876701 #884847
share|improve this answer
Separate report for Kernel updates:… Also note the Ubuntu Kernel Mapping: This list helps to determine which mainline version corresponds to the Ubuntu version. – lgarzo Nov 15 '11 at 10:26

This is helping many people the installation of Jupiter controls, the energy expenditure

sudo add-apt-repository ppa: webupd8team/jupiter
sudo apt-get update
sudo apt-get install jupiter
share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.