Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have unistalled and reinstalled the Ubuntu Software Center as per info I found in a similar thread and I got the same response about line 91 or something like that.

I just tried to upload a screen shot but since I'm new it won't allow me to. I also can not figure out how to cut and paste anything so I have to hand type what the error screen says, both when I attempt to open the software center and nothing happens, when I try to enter commands into the terminal to uninstall, reinstall, whatever I get the same following:

COULD NOT INTITIALIZE THE PACKAGE INFORMATION
An unresolvable problem occured while initializing the package information
Please report t:his bug against the 'update-manager' package and include the
following error message:
'E: Malformed line 91 in source list/etc/apt/sources.list (dist parse) 
E: The list of sources could not be read., 
E: The package list of status file could not be parsed or opened.

How do I report bugs? What can be done about this. I have searched and everything everyone says to do leads me back to the same line error message.

So, I don't know how to get to line 91 in the source list; to tell you what it says. Sorry, I'm really new to this. That is what I need is to find out how to get there and fix what it says. I would really like to NOT have to re partition my hard drive and start from scratch, so I'm really looking forward to getting this problem solved. I need to be able to install new software.

share|improve this question
6  
Can you add the content of your /etc/apt/sources.list between lines 67 and 69??? –  Bruno Pereira Jun 17 '12 at 17:10
1  
Edit your question to include the output of the command cat /etc/apt/sources.list. And no you don't need to wipe out everything. It is very easy problem (from my experience) –  Anwar Shah Jun 17 '12 at 17:14
add comment

6 Answers

You have to delete the last line of this file (not the file itself, of course):

 /etc/apt/sources.list

Your sources.list file has to look something like this:

# /etc/apt/sources.list
deb http://archive.ubuntu.com/ubuntu/ precise main restricted universe multiverse 
deb http://security.ubuntu.com/ubuntu/ precise-security main restricted universe   multiverse
deb http://archive.ubuntu.com/ubuntu/ precise-updates main restricted universe multiverse
deb http://archive.canonical.com/ partner
deb-src http://archive.canonical.com/ partner

Of course, just replacing your sources.list file with that text could be a very bad thing, especially if it looked quite different before. The key point is that each line starts with deb or deb-src (except for comments, which start with #).

share|improve this answer
    
Deleted and fixed. Thank you! –  Odi1215 Aug 3 '12 at 20:31
    
@Malika Hello, I'm glad this fixed the problem. But please try to answer questions not only for the asker, but also for people who Google this question and have slight variations of the asker's problem. This probably needs a little more explanation to make it a good "general" answer. :) –  Jacob Johan Edwards Sep 1 '12 at 14:08
    
@JacobJohanEdwards I can't agree with you, because we really can't help those people who execute commands before reading the question, IMO –  Anwar Shah Sep 1 '12 at 16:20
1  
@Anwar In my opinion, it is the responsibility of the answerer to (a) not answer in a way that only helps the original asker [that's too localized], (b) does not does not appropriately warn of the potential side effects of a command. A disclaimer helps. –  Jacob Johan Edwards Sep 1 '12 at 17:07
add comment

Those two lines are broken--they are missing the designation for which Ubuntu release you are running.

Edit /etc/apt/sources.list to fix the broken lines.

To do this, run this command (either press Alt+F2 and run it from there, or open a Terminal with Ctrl+Alt+T):

gksu gedit /etc/apt/sources.list

Find the two lines. As you've said in your question, they look like:

deb http://archive.canonical.com/ partner 
deb-src http://archive.canonical.com/ partner

Change them so they say this instead:

deb http://archive.canonical.com/ubuntu precise partner
deb-src http://archive.canonical.com/ubuntu precise partner

(precise because you're running Ubuntu 12.04, which I know because you tagged your question .)

Save the file and quit the text editor. Then run this command in a Terminal window:

sudo apt-get update

Assuming there are no errors, the problem is now fixed. You should be able to run the Sofware Center.

However, while some problems with the Software Center can be solved by reinstalling the software-center package, most cannot, so it's possible your original problem will remain. If that is the case, you can post a new question to get help with it.

share|improve this answer
add comment

The file /etc/apt/sources.list contains the URLs of webservers and location of other sources form (e.g. cds), from which you retrieve your software and updates. It basically tells Ubuntu where to look for new Software and updates to already installed programs. The error message you got means, that somehow the file got compromised. Without knowing what the content of your file is, it is hard to know what exactly is wrong with it. So you should post the output of sudo more /etc/apt/sources.list for us to help you better.

If the file is messed up beyond repair, you can use the Ubuntu Source List Generator to generate a sources.list anew. But you should backup your old one beforehand. Also this will cause you to lose all changes you have made for your Software Sources, e.g. in Sofware Center.

The better way to fix this is letting us see whats wrong with your sources.list

Edit after you posted your sources.list:

I believe the file you posted should look like this (note the last to lines and the missing /etc/apt/sources.list in the end):

# /etc/apt/sources.list

deb http://archive.ubuntu.com/ubuntu/ precise main restricted universe multiverse 
deb http://security.ubuntu.com/ubuntu/ precise-security main restricted universe multiverse
deb http://archive.ubuntu.com/ubuntu/ precise-updates main restricted universe multiverse
deb http://archive.canonical.com/ubuntu partner
deb-src http://archive.canonical.com/ubuntu partner
share|improve this answer
    
I'll try the source list generator after I backed up my files but it would really take a while. My laptop is still on HDD so it's not that quick yet. I added my source.list to the message above. –  Odi1215 Aug 1 '12 at 13:30
    
It is sufficient to back up just the one file called sources.list. –  con-f-use Aug 1 '12 at 13:32
    
Okay, will do. Then I'll try the source list generator? –  Odi1215 Aug 1 '12 at 13:35
    
Positive. That's a Yes. –  con-f-use Aug 1 '12 at 13:38
    
I typed in sudo more /etc/apt/sources.list but nothing happened. –  Odi1215 Aug 1 '12 at 16:58
show 3 more comments

Please paste file /etc/apt/sources.list so we can troubleshoot this problem for you. See this short tutorial answer for how to do that:

How do I share a text file (or command output) from my Ubuntu system with others?


This can sometimes be a very easy fix, but you must backup sources.list first since it's a critical file.

  1. Open the terminal with Ctrl-Alt-T
  2. Type/paste: sudo cp /etc/apt/sources.list /etc/apt/source.list.backup (this creates a backup copy)
  3. sudo sed -i -e '68d' /etc/apt/sources.list (this deletes the problematic line)
  4. sudo apt-update (this updates the database with the hopefully-fixed file)

If you see no errors appear when you try step 4, the problem is hopefully fixed. You can exit the terminal and go back to Software Center/Update Manager and it should work.

If there is still a problem, you can restore the original file from the terminal with sudo cp /etc/apt/sources.list.backup /etc/apt/sources.list. In that case, please paste the problematic lines or even the entire file to a pastebin and then we can help out further.

share|improve this answer
3  
Deleting the offending line may not be a good idea (but kudos on the advice to back things up before doing this). What if it's a repository the user needs? Also, if a long line was somehow split into two lines, you will have two malformed lines (and the procedure has to be repeated). man sources.list has a section with examples and it may be useful to ask the user to compare his lines with the examples, maybe he can determine what's wrong and fix it himself. Personally I'd wait until he posts his sources.list file. –  roadmr Jun 18 '12 at 0:04
    
@roadmr: Thanks, I agree completely with all of the scenarios you posit. I just felt that newbies may not even know how to post a file, let alone specific lines from that file, unless advised how. That inspired me to write this self-QA-howto :-) –  izx Jun 18 '12 at 7:45
add comment

Quick method:

A workaround for this problem can be building the sources.list entry from scratch.

deb http://archive.ubuntu.com/ubuntu precise main universe restricted multiverse
deb-src http://archive.ubuntu.com/ubuntu precise universe main multiverse restricted

deb http://security.ubuntu.com/ubuntu/ precise-security universe main multiverse restricted
deb http://archive.ubuntu.com/ubuntu precise-updates universe main multiverse restricted
deb http://archive.ubuntu.com/ubuntu precise-backports universe main multiverse restricted

# deb http://archive.canonical.com/ubuntu precise partner
# deb-src http://archive.canonical.com/ubuntu precise partner

# deb http://extras.ubuntu.com/ubuntu precise main
# deb-src http://extras.ubuntu.com/ubuntu precise main
  • Copy the above content (in grey box) and open sources.list file with root permission,

    Typing sudo gedit /etc/apt/sources.list this in a terminal and hitting Enter will do the job.

  • Then paste the copied content in the sources.list, then save and close gedit.

  • Then do sudo apt-get update and you will see that the repository list is updated.

Explanation: Here we are completely replacing the content with another sources.list file with repository entry from Main Server. If you want to use your local server for sources.list see the method below.

Recommended method:

Go to the Ubuntu sources list generator site

  • Select your country
  • Select your desired branches, such as Main, Restricted, Multiverse, Universe,
  • Select desired update list, -
  • Select any third party repository list if you wish,
  • Click Generate list at the bottom of the page, you will be given a list with repositories,
  • Copy that list and replace with sources.list file you have.

You are done.

Hope this will helps.

share|improve this answer
    
Strange that this was not accepted!! A quick fix, comment the problematic line in /etc/apt/sources.list by adding ## as first characters in the line. Then try sudo apt-get update. –  Noble P. Abraham Sep 12 '12 at 7:32
add comment

As you can see from the error, it says that your sources.list file has a wrong entry. This wrong entry could not be parsed. This error is not related to Software Center as such but mostly to do with apt(The package manager)

The way to solve this would be to fix the malformed line 91 entry.

If you cannot understand what is wrong with line 91, please post line 91 and I will help you out

share|improve this answer
add comment

protected by Community Jan 16 '13 at 20:38

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.