Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have been creating a custom live CD of Ubuntu 11.10 using remastersys, everything goes well except that the live session asks for a login. the login is automatically set as "custom" and the password is blank. this is fine, but I would rather it went direct to the desktop in a live session as you would expect from other distro live cds.

I have asked on the remastersys forums, the question has gotten a lot of views, but no answer as of yet, I am wondering has anyone here remastered a distro and come across the login problem, and if so, how did you fix it?

share|improve this question
    
Is this helpful? –  Manish Sinha Nov 13 '11 at 20:55
    
Im not sure, is this telling how to remove autoligin for a live session, when i want autologin for a live session, so if i do the reverse, the live session will go direct to the desktop? will this adversely affect login once the sysytem is installed? thanks for your help –  Jayo Nov 21 '11 at 23:47

3 Answers 3

Maybe this Gentoo documentation helps:

Build Your Own LiveCD or LiveDVD - AutoLogin

share|improve this answer
    
im not sure, this looks specific to gentoo? –  Jayo Nov 25 '11 at 22:28
    
If you're about to create a LiveCD, you probably can figure it out with this howto even when aimed for Gentoo. –  Marc-André Appel Feb 24 '12 at 18:29

Try configuring your login manager on the system to be remastered. Enable autologin there and I believe it will be the same in LiveCD. My root account password saves on remastered LiveCD and on installation of this remaster, so login manager's settings mostly save.
This is just a guess, though.

And you could also look at the new version of remastersys here, they added some options for grub customization and plymouth theme, so I believe you can enable autologin with that version aswell.

If anyone posts any good response, please ignore this one, since these are just guesses.

share|improve this answer
    
thanks for the reply, i should have mentioned that i am already using the latest remastersys and also fragadelic, the dev, earlier offered that having autologin would actually cause problems, though in my case i dont have autologin enabled –  Jayo Nov 25 '11 at 15:26

for solving this problem i was making Live-Cds the last three weeks day n night and i tried every tip and configuration-option in remastersys :-p !

But now i think i found the "problem" and my last 2 Live-Cd making with remastersys has no login-prompt anymore and starts with auto-login!

First let me tell you that you have to use the DISTRO-MODE and NOT the BACKUP-MODE! In Backup-Mode of Remastersys always your last user and password is saved!

And it really helps if you had a clean system-Install with Auto-login choosen first and NO encryption of your homefolder!

It doesn t matter if you have make password-prompt later on- but if you make your live-cd make Auto-Login ON again!

And now comes the "Trick": In the Gdm-Login-Manager-Preferences you can choose timebased Auto-Login under the normal Auto-Login option! THIS YOU HAVE TO MAKE ALWAYS ON TOO!!! for example: 10 seconds or something- but it has to be activated!

For me now it works and every Live-Cd i make with Remastersys is coming with auto-login! I tried this on Linux Mint 13 but this is based on Ubuntu 12.04 and so it has to work on other Ubuntu-Machines that using GDM/MDM-Login too!?!

Don't change anything in Users/groups-GUI!!!

I hope somebody will help this! I was going really mad about not finding out how it works! And at the end i was thinking: ok, so everybody has to use the login as "custom" without password- but without this prompt it makes more sence!

:-)

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.