Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I just installed a Logitech C310 webcam, on my onieric system, and I have a problem with it's audio. When recording sound from the webcam's source, the resuult is played very fast, in a very high pitch. I believe it has something to do with pulseaudio, since when I tried recording directly from alsa (by using audacity), the result was fine.

EDIT: I checked it further, and the problem occurs only after I switch between different users.

EDIT: I've also found a similar bug reported on Fedora.

share|improve this question
add comment

1 Answer 1

up vote 3 down vote accepted

I had the same problem and I found the the solution here

Open Terminal and use the next:

gedit $HOME/.pulse/daemon.conf

and put the following line on the file:

default-sample-rate = 16000

save it, and then restart pulseaudio as a user with the following command

pulseaudio --kill && pulseaudio --start

Do this for every user.

share|improve this answer
    
Thanks, I did this for every user, and now the recording is played back fine for one of the users, but the other user can't select the webcam source in sound settings. –  haggai_e Nov 16 '11 at 16:51
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.