Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a problem on which I'm struggling since i started using linux a year ago on my desktop, but still haven't found a solution for it. When reading or burning a dvd, the speeds are very slow (mostly under 1x) whilst I did selected the fastest speed in k3b. As such, it takes up to 40-50 minutes to burn one dvd! I read about enabling dma this post but it didn't help. This is the output for dmesg | grep -i dma

> [    0.000000]   DMA      0x00000010 -> 0x00001000
[    0.000000]   DMA32    0x00001000 -> 0x00100000
[    0.000000]   DMA zone: 56 pages used for memmap
[    0.000000]   DMA zone: 5 pages reserved
[    0.000000]   DMA zone: 3921 pages, LIFO batch:0
[    0.000000]   DMA32 zone: 3527 pages used for memmap
[    0.000000]   DMA32 zone: 254441 pages, LIFO batch:31
[    0.000000] Policy zone: DMA32
[    0.120356] pnp 00:01: [dma 4]
[    0.120968] pnp 00:05: [dma 2]
[    0.121421] pnp 00:06: [dma 3]
[    0.122617] pnp 00:0b: [dma 0 disabled]
[    0.852321] ata1: SATA max UDMA/133 cmd 0xec00 ctl 0xe480 bmdma 0xe000 irq 19
[    0.852325] ata2: SATA max UDMA/133 cmd 0xe400 ctl 0xe080 bmdma 0xe008 irq 19
[    0.861633] ata3: PATA max UDMA/133 cmd 0x1f0 ctl 0x3f6 bmdma 0xff00 irq 14
[    0.861636] ata4: PATA max UDMA/133 cmd 0x170 ctl 0x376 bmdma 0xff08 irq 15
[    1.329411] ata1.00: ATA-7: Maxtor 6V250F0, VA111630, max UDMA/133
[    1.345418] ata1.00: configured for UDMA/133
[    1.820606] ata4.00: ATAPI: PHILIPS DVDR1660P1, P1.3, max UDMA/33
[    1.820610] ata4.00: WARNING: ATAPI DMA disabled for reliability issues.  It can be enabled
[    1.820613] ata4.00: WARNING: via pata_ali.atapi_dma modparam or corresponding sysfs node.
[    1.836681] ata4.00: configured for UDMA/33
[   12.296600] parport0: PC-style at 0x378 (0x778), irq 7, dma 3 [PCSPP,TRISTATE,COMPAT,EPP,ECP,DMA]

reading the third and fourth last line, I assume there is indeed a problem with dma?

edit: this question still is not solved. Could anyone come up with an other solution please? Thanks

share|improve this question
    
How is your drive connected to your PC? –  con-f-use Apr 25 '12 at 13:14
add comment

1 Answer 1

Add a file in etc/modprobe.d/ with the name aliases

sudo gedit /etc/modprobe.d/aliases

with these contents

## Turn on DMA for DVD ############################
alias ata_generic off
alias pata_atiixp on

and reboot

sudo reboot

(source: https://help.ubuntu.com/community/DMA)

share|improve this answer
    
It did not help. Even when I deleted the changes I've made to /etc/initramfs-tools/modules , it still gives me speeds around 1x. The output of dmesg | grep -i dma remains the same... –  wouter205 Nov 13 '11 at 16:02
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.