Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

As i am playing avi videos on my newly installed Xubuntu i observe video flickering because of which i do not get optimal user experience while watching videos. I have tried multiple players as well as multiple videos but the problem persists. The flickering doesnt exist when i am playing my video on win 7.

info driver:- amd radeon 4500 propriety driver activated players tried:- mplayer, vlc

share|improve this question
add comment

1 Answer 1

If you have xubuntu's compositor active (only supports drop shadows and transparency), try running mplayer with -vo gl or -vo gl2. If this does not help, try turning the compositor off (settings/window manager tweaks, rightmost tab).

share|improve this answer
1  
I find that you need to turn off the compositor for vlc to play correctly in fullscreen, but not mplayer based programs like gnome-mplayer. In general, I find that the compositor causes big problems with hardware accelerated video overlays. –  user76204 Aug 26 '12 at 23:24
    
Disabling the compositor made the flickering when watching DVDs go away for me :-) –  Sebastian Blask Mar 16 '13 at 20:26
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.