Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Hey I have a sentelic touchpad that doesn't work very well in linux, its supposed to be all multi-touch and such, it works all right in window. I really am not a fan of using windows though. the worst thing that it does is that it doesn't disable itself when typing, so it will always take focus away. I can disable it with modprobe -r psmouse but it would be nice to have it do this automatically.

Also if you can think of a workaround to re-enable it automatically that would be great :)

share|improve this question
    
When you say "automatically" do you mean at the moment you begin typing? I'm not sure this is possible but you could run a script once you have decided to begin typing. –  DeoxNa Nov 13 '11 at 3:03

2 Answers 2

up vote 1 down vote accepted

I eventually found a solution. As almost always someone smarter than me had the same problem, and also a solution :) github.com/gokmen/Sentelic. –

Sentelic


Sentelic Mouse (Asus UX31) disable daemon while typing.

First install Xlib and Udev Python bindings. (Udev Python bindings are optional though)

You need root priviligese to run the daemon.

$ sudo ./sentelic.py

Default timeout is 0.9 sec. You can define the timeout in /etc/sentelic.conf:

timeout=1.5
share|improve this answer

Write 2 bash scripts where ever you would like, for the purpose of this let's just say in your home directory. Create two empty documents in your home directory. Name the first one Enable Touchpad and the other Disable Touchpad. Insert the following text in "Enable Touchpad"

#!/bin/bash
sudo modprobe psmouse

Insert the following into the second one:

#!/bin/bash
sudo modprobe -r psmouse

Now make both files executable by right clicking on them-> Properties -> Permissions -> Check the box that says "Allow executing file as program".

Open the keyboard preference window. If you're in Unity this can be done by typing keyboard into the dash, or by opening system settings -> keyboard. Now go to the "Shortcuts" tab. Go to "custom shorcuts" and click on the "+" button. Name the first "Enable touchpad" and as a command encase the location of the appropriate script '/user/home/Enable Touchpad'. Make a second shortcut for disabling the touchpad, naming and pointing to the correct script: '/user/home/Disable Touchpad'

Finally click on the new keyboard shortcuts so they begin grabbing key combinations. Enter your desired key combo. Now, when ever you're going to start typing just disable the touchpad through the key combo, when your done re-enable.

**Note: Since modprobe requieres root acces, you will have to type in your password whenever you enable/disable.

share|improve this answer
    
this isn't quite what I want, I want it to be disabled by any keystroke and re-enable it after say 5 seconds of not typing. –  vanjoe Jan 6 '12 at 6:10
1  
I eventually found a solution. As almost always someone smarter than me had the same problem, and also a solution :) github.com/gokmen/Sentelic. –  vanjoe Jan 17 '12 at 18:13

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.