Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Recently I encountered dependencies resolve issues when using APTITUDE (it is my favorite). Nevertheless, I started to feel that APTITUDE does not behave as it is supposed to be in 64 bits systems while apt-get works fine.

Can someone confirm that APTITUDE is buggy in Ubuntu 11.10 amd64?

Edit: For example, when tried to install ntfs-config using APTITUDE, it asked me to remove over 100 packages (skype for example), while using apt-get worked fine.

han@L502X:~$ sudo aptitude install ntfs-config 
[sudo] password for han: 
The following NEW packages will be installed:
  ntfs-3g{ab} ntfs-config 
0 packages upgraded, 2 newly installed, 0 to remove and 0 not upgraded.
Need to get 0 B/640 kB of archives. After unpacking 2,466 kB will be used.
The following packages have unmet dependencies:
  ntfs-3g: Conflicts: ntfsprogs but 2.0.0-1ubuntu4 is installed.
The following actions will resolve these dependencies:

       Remove the following packages:                                    
1)       flashplugin-downloader                                          
2)       flashplugin-installer                                           
3)       libasound2                                                      
4)       libasound2-plugins                                              
5)       libasyncns0                                                     
6)       libatk1.0-0                                                     
7)       libaudio2                                                       
8)       libavahi-client3                                                
9)       libavahi-common3                                                
10)      libc6                                                           
11)      libcairo2                                                       
12)      libcomerr2                                                      
13)      libcups2                                                        
14)      libcurl3                                                        
15)      libdatrie1                                                      
16)      libdb5.1                                                        
17)      libdbus-1-3                                                     
18)      libdbusmenu-qt2                                                 
19)      libexpat1                                                       
20)      libffi6                                                         
21)      libflac8                                                        
22)      libfontconfig1                                                  
23)      libfreetype6                                                    
24)      libgcc1                                                         
25)      libgcrypt11                                                     
26)      libgdk-pixbuf2.0-0                                              
27)      libglib2.0-0                                                    
28)      libgnutls26                                                     
29)      libgpg-error0                                                   
30)      libgssapi-krb5-2                                                
31)      libgtk2.0-0                                                     
32)      libice6                                                         
33)      libidn11                                                        
34)      libjack-jackd2-0                                                
35)      libjasper1                                                      
36)      libjpeg62                                                       
37)      libjson0                                                        
38)      libk5crypto3                                                    
39)      libkeyutils1                                                    
40)      libkrb5-3                                                       
41)      libkrb5support0                                                 
42)      liblcms1                                                        
43)      libldap-2.4-2                                                   
44)      libmng1                                                         
45)      libnspr4                                                        
46)      libnspr4-0d                                                     
47)      libnss3                                                         
48)      libnss3-1d                                                      
49)      libogg0                                                         
50)      libpango1.0-0                                                   
51)      libpcre3                                                        
52)      libpixman-1-0                                                   
53)      libpng12-0                                                      
54)      libpulse0                                                       
55)      libqt4-dbus                                                     
56)      libqt4-declarative                                              
57)      libqt4-network                                                  
58)      libqt4-script                                                   
59)      libqt4-sql                                                      
60)      libqt4-xml                                                      
61)      libqt4-xmlpatterns                                              
62)      libqtcore4                                                      
63)      libqtgui4                                                       
64)      librtmp0                                                        
65)      libsamplerate0                                                  
66)      libsasl2-2                                                      
67)      libsasl2-modules                                                
68)      libselinux1                                                     
69)      libsm6                                                          
70)      libsndfile1                                                     
71)      libspeexdsp1                                                    
72)      libsqlite3-0                                                    
73)      libssl1.0.0                                                     
74)      libstdc++6                                                      
75)      libtasn1-3                                                      
76)      libthai0                                                        
77)      libtiff4                                                        
78)      libuuid1                                                        
79)      libvorbis0a                                                     
80)      libvorbisenc2                                                   
81)      libwrap0                                                        
82)      libx11-6                                                        
83)      libxau6                                                         
84)      libxcb-render0                                                  
85)      libxcb-shm0                                                     
86)      libxcb1                                                         
87)      libxcomposite1                                                  
88)      libxcursor1                                                     
89)      libxdamage1                                                     
90)      libxdmcp6                                                       
91)      libxext6                                                        
92)      libxfixes3                                                      
93)      libxft2                                                         
94)      libxi6                                                          
95)      libxinerama1                                                    
96)      libxrandr2                                                      
97)      libxrender1                                                     
98)      libxss1                                                         
99)      libxt6                                                          
100)     libxv1                                                          
101)     nspluginviewer                                                  
102)     nspluginwrapper                                                 
103)     ntfsprogs                                                       
104)     skype                                                           
105)     sni-qt                                                          
106)     zlib1g                                                          

       Leave the following dependencies unresolved:                      
107)     flashplugin-downloader recommends libasound2-plugins (>= 1.0.16)


Accept this solution? [Y/n/q/?] 
share|improve this question
3  
I've never had trouble with aptitude in 64-bit. You write that you "feel" that it's buggy, could you elaborate to make your claim more substantial? –  N.N. Nov 12 '11 at 21:45
3  
It is true that aptitude and apt-get act differently in some circumstances, with respect to resolving dependency conflicts. However, aptitude is generally considered to be the more advanced of the two. If you find that there is an action you are able to perform with apt-get which you are unable to perform with aptitude due to dependency resolution problems, please post all the text from the Terminal showing both the successful attempt with apt-get and the unsuccessful attempt with aptitude. (You can edit your question to add this information.) –  Eliah Kagan Nov 12 '11 at 22:34
    
I edited the question. –  Hanynowsky Nov 12 '11 at 23:20
2  
This does sound like something that should be reported as a bug. –  WarriorIng64 Nov 13 '11 at 1:14

1 Answer 1

up vote 3 down vote accepted

It is not just buggy - it is completely broken and unusable. It is tracked by this bug report (and its duplicates):

https://bugs.launchpad.net/ubuntu/+source/aptitude/+bug/831768

No fix in site until next release. What an embarrassment!

share|improve this answer
    
That is what I doubted! :( Embarrassing indeed! wow! No aptitude untill April! Thanks @vldmrrr for the confirmation! –  Hanynowsky Nov 22 '11 at 14:31

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.