Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am on Gnome-Shell and using Ubuntu 11.10.

The problem is after a recent update and also after installing a few extensions, when I logged in to Gnome Shell, I can't find the top panel or AWN. Only the wallpaper is showing and then Conky is displaying.

It also seems to me that for some reason the display effects are not working and that is why AWN is not showing.

Need your help to get back the panel.

share|improve this question
up vote 2 down vote accepted

Something similar happened to me. I think the issue is that some of the extensions are buggy and crash the shell. I am not certain but I think this might be because they were badly upgraded from gnome shell 3.0 (I'm not much of an expert as you can probably tell).

Anyway, I fixed problem by logging on in Unity (so I got a fully workable desktop) and then using synaptic to remove packages starting "gnome-shell-extensions-" -

Try removing the alternative menu status one first- that is reported as buggy as far as I can see.

share|improve this answer
It worked!! Thanks for your help. Earlier I tried by removing the extensions that I installed last. That is because I thought there might be some buggy one among them. But that didn't worked. I also removed alternative menu status one but that too didn't work. Now I tried by removing all and then it worked. Thanks for your help. – Arindom Nov 13 '11 at 2:20

I had the same problem, it's a bug with alternate menu, you must define a user avatar (small picture next your name) and all will be fine.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.