Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

In the most specific, unemotional terms:

  • Reinstalled os, using 11.10(1 month after release to skip initial issues that usually crop up).

  • Configured system to my specifications(just ways of organizing config files, etc).

  • Log out

  • Log back in after after an hour or so...to find my home directory obliterated and just a few skeleton files existing.

  • think oh well, try again (this has happened before with an install for reasons I've never been able to pinpoint, usually around install time with some sort of update but its never been a major recurring issue)

  • same thing happens

  • I thought something was awry, so I reinstalled again (another 20 minutes, meh)

  • Set up system, arranged home directory a bit differently thinking maybe I tread on something I shouldn't have.

  • log out, come back --- the same thing. Most of the directories I added were deleted (e.g. .xmonad which links to xmonad.hs in my portable config directory)

tl;dr every change I make in my home directory gets deleted.

I'll willingly fill in details as needed, this was just a start to see if anyone can help, I've found no trace of this issue in a search.

EDIT: mount/df -h info, in the spirit of being helpful

/dev/mapper/sda1_crypt on / type ext4 (rw,errors=remount-ro,commit=0)
proc on /proc type proc (rw,noexec,nosuid,nodev)
sysfs on /sys type sysfs (rw,noexec,nosuid,nodev)
fusectl on /sys/fs/fuse/connections type fusectl (rw)
none on /sys/kernel/debug type debugfs (rw)
none on /sys/kernel/security type securityfs (rw)
udev on /dev type devtmpfs (rw,mode=0755)
devpts on /dev/pts type devpts (rw,noexec,nosuid,gid=5,mode=0620)
temp on /tmp type tmpfs (rw,noexec,nosuid,nodev,noatime,size=700M,mode=1777)
tmpfs on /run type tmpfs (rw,noexec,nosuid,size=10%,mode=0755)
none on /run/lock type tmpfs (rw,noexec,nosuid,nodev,size=5242880)
none on /run/shm type tmpfs (rw,nosuid,nodev)
vartemp on /var/tmp type tmpfs (rw,noexec,nosuid,nodev,noatime,size=50M)
/dev/sdc1 on /boot type ext4 (rw,commit=0)
binfmt_misc on /proc/sys/fs/binfmt_misc type binfmt_misc (rw,noexec,nosuid,nodev)
gvfs-fuse-daemon on /home/ka/.gvfs type fuse.gvfs-fuse-daemon (rw,nosuid,nodev,user=ka)


Filesystem            Size  Used Avail Use% Mounted on
/dev/mapper/sda1_crypt
                       19G  4.4G   14G  26% /
udev                  3.9G  4.0K  3.9G   1% /dev
temp                  700M   16K  700M   1% /tmp
tmpfs                 1.6G  928K  1.6G   1% /run
none                  5.0M     0  5.0M   0% /run/lock
none                  4.0G  1.3M  4.0G   1% /run/shm
vartemp                50M  8.0K   50M   1% /var/tmp
/dev/sdc1             369M   39M  312M  12% /boot

note, none of the directories/files are files that would be outside my home directory, i.e. nothing weird or obscure, just config files that would be there to begin with. My tmp/vartmp are non standard(memory only mounted on boot), perhaps I need to look at those again (which I haven't for a while). The install is on an encrypted lvm if that counts as well.

EDIT2:

With a fresh install,doing only incremental and least radical changes, this happened yet again. This was after I went into an xmonad session, after installing chromium-browser. So one of two issues: my xmonad session (where I start gnome-settings-daemon, no problems previous although that would be my immediate random guess) or the chromium-browser install.

Still really, really irritating and preventing from moving on with my install :/

EDIT3:

STILL happening, even with the merest changes. I've had problems with Ubuntu, but this is an issue with the Ubuntu I've grown accustomed to using.

EDIT4:

Suggestions on another forum indicate that this could be an issue with the encryption, which I use in setup but am not an expert in understanding its inner workings. I can find no trace of my specific issue, but then again I'm not sure where to look (meaning, I use Ubuntu but I'm not at all conversant with bug/issue searching because I've had few problems and have been able to solve what few problems that cropped up). I may just install 10.04LTS in the meantime.

share|improve this question
    
Could you add the output of mount so we can see what is mounted, and maybe also df -h to see diskspace. –  Hamish Downer Nov 12 '11 at 17:35
1  
I'd advise against moving and rearranging config files. Despite your conviction that you should be able to do whatever you want, it's not that simple. You have to first know what to do, as well as how. –  mikewhatever Nov 12 '11 at 18:27
    
mikewhatever, No. These are really basic files for xmonad, zsh, icons, fonts, h/top, etc. Really, really basic stuff I need to run my system to my specification. Things that have been working for over 3 years across(6 instances of Ubuntu releases...) a number of computers and laptops of varying configurations. Things I know what I'm doing with. Your comment has no place in this discussion kthx –  long-time user....2006 Nov 12 '11 at 19:01
1  
Sure. I'm a Ubuntu noob, hanging out here to pick up bits of knowledge of how it all hangs together, given that I can't actually find a single resource (site, book) which explains to a technically minded developer/linux noob how it all works. So that's just what I'd do. –  Poldie Nov 12 '11 at 21:35
2  
First things first: you do not write what changes you are doing. For example, if you create an empty file in your home directory called "test" (touch test), log out / restart the system, will it disappear? If yes, then it is a problem with encryption / cacheing / disk access; if not, post what changes you are doing. Also, do dmesg and look for any strange things (like the word "error"). Also, do the same with /var/log/syslog. –  January Aug 20 '12 at 10:47
show 6 more comments

1 Answer

What you need to do is firstly set up your home directory in a separate partition.

In the install program select set-up partitions manually. Then create a root "/" partition, this should be around 20Gb, set a swap partition the rule of thumb here is 2x memory size, though you can make it bigger if you want.

Then create a new partition from the rest of the space and assign it to "/home" If this is the first install then you will need to format this.

When you reinstall then go through the same procedure, but this time the partitions will already exist, so you only need to set the partition root, "/" swap, and "/home" set the format partition option on the "/" but NOT on the "/home" partition.

This will then wipe the "/" directory but not the "/home". After the install program you will have all the system files in "/". Files in "/home" will still be there but the installer may have changed some "." files in here because of changes settings etc.

It can be useful to delete some or all of the "." files before doing this if you want the appearance to be at the default after the install.

share|improve this answer
    
You do realize that his question isn't about /home being nuke upon reinstalling, but upon logout/login, right? –  Shauna Aug 30 '12 at 14:36
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.