Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I can't launch the Software Center anymore. I've got a blank window each time I try to open it. I have tried to repair it by typing "software-center" in Synaptic Packages Manager, and I selected it for reinstall, but it still doesn't work. I'm on Ubuntu 11.10. Can you help me please ?

  • Running sudo apt-get update didn't fix the problem

Here is the standard output seen on the console:

2012-06-21 17:15:58,122 - softwarecenter.ui.gtk3.em - INFO - EM's: 17 15 21
share|improve this question
4  
Try to start software-center from terminal. Update question with the output. –  lgarzo Nov 12 '11 at 17:32
    
If the advice in this answer doesn't help, have you tried the Package Manager Troubleshooting Procedure? (Do steps 1-4, then post the text from the terminal on Ubuntu Pastebin and post a link to it here.) –  Eliah Kagan Nov 13 '11 at 3:00
add comment

2 Answers

up vote 3 down vote accepted

According to this bug there are two workarounds.

  1. killall software-center or
  2. Reboot your system.

If this is permanent, you can check its log file: ~/.cache/software-center/software-center.log

share|improve this answer
    
Thanks very much! –  Drew Noakes Jun 21 '12 at 22:42
add comment

I have had this same bug before, and I solved it by removing the Ubuntu Software Center (sudo apt-get remove software-center) and installing it again (sudo apt-get install software-center)

share|improve this answer
    
Reinstalling didn't work for me unfortunately. –  Drew Noakes Jun 21 '12 at 22:39
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.