Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm experimenting with using a Linode VPS as a development box for my Rails projects, so I'd like to set up a GUI environment to run a few basics, like Google Chrome for debugging.

There is a pretty good tutorial on installing VPC and Gnome here, and I've followed it closely. Everything seems to run correctly, but when I try to log in from the VNC client, I'm getting a message:

Failed to load session 'ubuntu.' 

This is on a default gray screen accompanied by a logout button and black X.

I'm thinking the issue is with my .vnc/startup file, but I'm not sure where to start troubleshooting. I tried logging in from different clients on Windows and my local Ubuntu box. I also tried rebuilding the VPS from the start and got the same result.

Any suggestions?

EDIT: I checked the session log file, and here are the errors reported. I'm thinking the font errors aren't a big deal, but the security policy error seems like a problem.

Xvnc Free Edition 4.1.1 - built Sep  7 2011 11:26:15
Copyright (C) 2002-2005 RealVNC Ltd.
See http://www.realvnc.com for information on VNC.
Underlying X server release 40300000, The XFree86 Project, Inc


Sat Nov 12 04:54:40 2011
 vncext:      VNC extension running!
 vncext:      Listening for VNC connections on port 5901
 vncext:      created VNC server for screen 0
error opening security policy file /etc/X11/xserver/SecurityPolicy
Could not init font path element /usr/X11R6/lib/X11/fonts/Type1/, removing from list!
Could not init font path element /usr/X11R6/lib/X11/fonts/Speedo/, removing from list!
Could not init font path element /usr/X11R6/lib/X11/fonts/misc/, removing from list!
Could not init font path element /usr/X11R6/lib/X11/fonts/75dpi/, removing from list!
Could not init font path element /usr/X11R6/lib/X11/fonts/100dpi/, removing from list!
Could not init font path element /usr/share/fonts/X11/Type1/, removing from list!
Could not init font path element /usr/share/fonts/X11/75dpi/, removing from list!
Could not init font path element /usr/share/fonts/X11/100dpi/, removing from list!
share|improve this question

2 Answers 2

Add some parameters to launch gnome-session in your ~/.vnc/xstartup file

gnome-session --session=gnome-classic &

or

exec gnome-session --session=gnome-classic &
share|improve this answer
    
Adding 'gnome-session ...' as the last line in my xstartup worked !! I also had to do a vncserver -kill :1 followed by vncserver :1 -depth 16 -geometry 1028×1024. Following that I was able to connect through 'Chicken of the VNC' –  Ashutosh Jindal Sep 14 '12 at 6:25

You could also just use X forwarding over ssh to launch chrome from that system.

ssh -X and then just launch chromium-browser

share|improve this answer
1  
where to write ssh -X and how to launch chromium-browser ? –  motto Feb 13 '13 at 11:59

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.