Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am trying to load v11.04 onto my HP desktop hard drive using a USB drive. I used the same USB drive to load the system on my Dell netbook and it loaded successfully. But trying to load on the desktop I get the error

Apt configuration problem. An attempt to configure apt to install additional packages from the CD failed

The installer then crashes. I have nothing in the CD drive. I can boot the system from the USB drive and it works fine. I have tried all options on the load with the same crash each time. I baffled as I successfully loaded my netbook with the same USB with no problems.

share|improve this question

closed as off-topic by Braiam, Thomas W., Avinash Raj, minerz029, don.joey Dec 16 '13 at 9:50

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "Bug reports and problems with the development version of Ubuntu should be reported on Launchpad so that developers can see, track and fix these issues." – Braiam, Thomas W., Avinash Raj, minerz029, don.joey
If this question can be reworded to fit the rules in the help center, please edit the question.

    
Hi Paul, can you boot the machine again and immediately when you see the little person and keyboard icons at the bottom center the screen, press the Space bar & select your language & then choose "Check disc for defects"? If it fails, is it possible to try re-making the USB drive? Also, what method did you use to create the USB? –  Jayson Rowe Nov 12 '11 at 1:58
    
By load, do you mean install? –  mikewhatever Nov 12 '11 at 2:02
    
bug in ubiquity bugs.launchpad.net/ubuntu/+source/ubiquity/+bug/658865 CONFIRMED but not solved. –  Braiam Dec 16 '13 at 2:31

1 Answer 1

Firstly, I assume you are trying to install Natty on your HP desktop from a USB.

So, I looked up the error and reached Ubiquity bug 768239 where comment 11 is might be useful.

Bug 768239 is
11.04 Installer crashed, apt configuration problem:
InstallStepError: >AptSetup failed with code 127

Notes in that comment suggest bug 658865 is the cause for this...

When trying to install Ubuntu 10.10 from USB, ubiquity crashes with this message: "An attempt to configure apt to install additional packages from the CD failed."

Root of problem
The problem is that the file structure on the usb differs to what is on a livecd and apt-setup is unaware of this.

That bug goes on to discuss two alternatives.

  1. Remove the script that causes the error, when installing from a Live setup ("Try Ubuntu"):

    sudo rm /usr/lib/ubiquity/apt-setup/generators/40cdrom

  2. Create the files as they are expected
    To resolve this, simply copy the contents of filesystem.squashfs on the iso into the usb stick.

You'll get more context in the two bug records.

share|improve this answer
    
Removing the script worked for me in Ubuntu 13.10. Thanks! –  Pablo Oct 17 '13 at 21:27

Not the answer you're looking for? Browse other questions tagged or ask your own question.