Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I installed Ubuntu 11.10 on my laptop. The main reason I switched to Ubuntu is because I wanted to use Compiz.

The first thing I did was to go to Additional Drivers and install ATI/AMD Proprietary FGRLX Graphics Driver. There was also another one available, ATI/AMD Proprietary FGRLX Graphics Driver (post-release updates), but I didn't install that one, because it basically meant the same thing to me as the one I already installed.

Next, I went to the ubuntuguide.org Oneiric Wiki

http://ubuntuguide.org/wiki/Ubuntu:Oneiric#Compiz_Fusion

So I followed the instructions there and ran this command in terminal:

sudo apt-get install compiz compizconfig-settings-manager compiz-fusion-plugins-main compiz-fusion-plugins-extra emerald librsvg2-common

But then, the terminal window said that the package "emerald" could not be found. So, I ran this command instead:

sudo apt-get install compiz compizconfig-settings-manager compiz-fusion-plugins-main compiz-fusion-plugins-extra 

After that, I installed Fusion Icon by running this command:

sudo apt-get install fusion-icon

I restarted my computer, searched for Compiz Config Settings Manager, and clicked on it. Then, I activated Wobbly Windows. I logged off and logged back on again, but there was no wobbly windows effect.

So I tried clicking on Fusion Icon, but it never started. Can someone please tell me what I did wrong here? Because I see everyone seems to be able to run Compiz except me. I really need to start Compiz, or else I think I'm going to uninstall Ubuntu.

share|improve this question
2  
I edited your question to reflect the change from compiz-fusion to compiz. BTW that guide you followed is outdated. –  RolandiXor Nov 12 '11 at 0:09

1 Answer 1

up vote 4 down vote accepted

Looks to me like you installed some incorrect packages thanks to a bad guide (it's obviously outdated or poorly done).

I'll try my best to walk you through how to fix it.

Fusion Icon:

Firstly, the fusion icon does not work anymore. It is no longer supported in Ubuntu because it does not use an indicator. There is an alternative (Displex) which you can install.

However, this is a third part tool, and if you are using the Unity (3D) Desktop I would not necessarily suggest you use it unless you know what you are doing (you can end up losing your entire Desktop session. Furthermore, the options Displex provides are not that useful in Unity 3D (for the most part).

This is not to say that Displex is not useful (it is actually), but in your case I would avoid it (therefore I have not provided a link).

Package Names:

Secondly, the packages you tried to install have been renamed (because Compiz-fusion literally fused back into Compiz). The packages you pulled in are "dummy-packages"

I have listed the plugins you can install (for a stable config) here:

compiz-plugins-extra - Collection of extra plugins from OpenCompositing for Compiz
compiz-plugins - OpenGL window and compositing manager - plugins
compiz-plugins-default - OpenGL window and compositing manager - default plugins
compiz-plugins-main - Compiz plugins - main collection

Emerald:

Finally, Emerald is no longer maintained (really) and it is not recommended on a modern desktop. If you try to run it within Unity it will probably not work.

To get a good config going again:

I would suggest you reset your Compiz configuration to the defaults. To do this, run:

unity --reset

in a terminal. This will reset Unity (including any shortcuts you have added to the launcher) as well as Compiz, and should give you a clean slate to work from, without affecting any files, start up programs, etc.

From there, you should be able to customize your Compiz setup with Compiz Config Settings Manager as you like.

To start Compiz after this:

First restart your system (if you have not already done so) to ensure that the fglrx driver is loaded (before you attempt to run Compiz). When you log in, You should see something similar to this:

Unity Unity Desktop. Ignore the customization, and the album cover artwork on my Desktop :)

If you do not see this, then it means than Compiz is likely crashing. If you get a message saying that you cannot run Unity, then you have an issue with your drivers.

If all goes well, open the Dash (using the top-most icon in the launcher) and type "ccsm" to get CompizConfig-Settings-Manager, and then click on it's icon. From there customizing Compiz should be a breeze.

By the way, please note that you cannot enable the Desktop Cube by default (because of an incompatibility between Unity and the Desktop Cube). There are guides covering how to do this, so I will not cover it here.

share|improve this answer
    
@jasoncruz98 there are several ways to do it. In this case I used sudo apt-cache search compiz. Btw if this answer was the solution, you can click the green tick next to it to mark it as answered. If it was not, let me know ASAP :) –  RolandiXor Nov 12 '11 at 0:54
    
After I install the packages you have said, what do I do to start Compiz to enable effects? –  jasoncruz98 Nov 12 '11 at 0:58
    
@jasoncruz98 are you using the Unity Desktop? askubuntu.com/questions/62001/am-i-using-unity-or-unity-2d –  RolandiXor Nov 12 '11 at 1:02
    
@jasoncruz98 see my update. –  RolandiXor Nov 12 '11 at 1:13
    
Now I know, I was actually using Unity 3D before I installed the driver for ATI Radeon. But after I installed it, it automatically changed to Unity 2D. I am using Unity 2D. Should I change to Unity 3D to run Compiz and how do I do it? –  jasoncruz98 Nov 12 '11 at 1:24

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.