Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a very odd problem with Ubuntu 11.10. Here is a picture of it:This *is* a maximized window

The window in the picture is maximized, but for some odd reason it does not cover the entire desktop area. That area of the desktop the window does not cover is a dead area - I also can't drag desktop items to there, though I can drag not-maximized windows to that area.

Rebooting doesn't help. The problem started after I configured some windows partitions to automount on startup(though I don't see how that could cause the problem...)

Does anyone know a way to fix this?

share|improve this question

closed as off topic by jrg May 21 '12 at 20:44

Questions on Ask Ubuntu are expected to relate to Ubuntu within the scope defined by the community. Consider editing the question or leaving comments for improvement if you believe the question can be reworded to fit within the scope. Read more about reopening questions here.If this question can be reworded to fit the rules in the help center, please edit the question.

    
Hi Idan, is this a default install? Was it like this out of the box, or have you tweaked anything (in CCSM, for example)? Also, what video card and drivers are you using (if you know). Thanks! –  Jayson Rowe Nov 12 '11 at 1:51
    
@JaysonRowe: Well, default install always freezed on me, so I used the alternate CD and set it to not update the software as part of the install(I updated it after it was installed). I'm a Linux newbie, so I don't really know how to tweak with Linux configurations, but I did install some stuff with apt-get - vim-gtk,lyx,culmus,livetex,and git, and in the gui department gtk,gtk-pixbuf and tint2, which I tweaked a bit with tintwizard. My graphics card is GForce GT 335M, and I installed the nvidia unix driver after the default driver alwayz made my Ubuntu freeze after 10 minutes. –  Idan Arye Nov 12 '11 at 2:00
1  
Ok, none of that seems dangerous. I was just making sure you hadn't tweaked any Compiz settings. Can you select a "Unity 2D" session on the login screen to see if it happens with the Compiz (the 3D desktop rendering engine) disabled? –  Jayson Rowe Nov 12 '11 at 2:05
    
Also, did this only happen after selecting the Nvidia drivers? Did it ever work w/ the Nvidia drivers? –  Jayson Rowe Nov 12 '11 at 2:06
    
@Jayson: You are my savior - switching to 2D fixed the problem! It also solved my other problem. MMMmmm... since the problem is the desktop manager, and unity2D is not as good in functionality as regular unity(workspaces in row instead of circles, can't switching between windows of the same programs with Alt+Tab or with tint2, and that's just what I noticed in the 5 minutes since I logged in with 2D), I might just switch to GNOME Shell... Anyways, please post it as an answer so I can accept it. –  Idan Arye Nov 12 '11 at 2:42

1 Answer 1

up vote 0 down vote accepted

I'll speculate that this was caused by a window manager strut reserving space at the top edge of the screen:

The purpose of struts is to reserve space at the borders of the desktop. This is very useful for a docking area, a taskbar or a panel, for instance. The Window Manager should take this reserved area into account when constraining window positions - maximized windows, for example, should not cover that area.

tint2, which you mentioned having installed, will do precisely this in accordance with its panel geometry and strut_policy configuration options.

share|improve this answer
    
Thanks, but it doesn't bother me anymore, since I moved to GNOME Shell –  Idan Arye Nov 13 '11 at 21:08

Not the answer you're looking for? Browse other questions tagged or ask your own question.