Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Can the "navigation buttons" (forward and back) in nautilus 3 be moved to the left? I just find them impractical and confusing on the right. This is nautilus looks by default:

enter image description here

I would like to move the forward and back buttons to the left of the "location bar". The search button could be left there. Is it possible?

Edit: I posted this as as a bug to the Gnome developers. If you also feel the toolbar should be customizable, suscribe to the bug report in the following link:

https://bugzilla.gnome.org/show_bug.cgi?id=664311

share|improve this question
4  
Three people have already fallen into the trap but please note: we're not talking about the window buttons, rather back, forward, up, search, etc –  Oli Nov 11 '11 at 23:04
add comment

5 Answers 5

enter image description here

nyteryder79 figured it out and posted his instructions in this forum thread:

It's really easy to do, and I've got the easy Terminal instructions below. BTW, the version of Nautilus current as of this post is 3.2.1. You will probably need to do this any time Nautilus gets updated through Update Manager. The exact line number of the code that needs to change may vary as well. If this is the case, just use find as I instruct below.

Warning: I am not a professional and am not responsible for anything going wrong. These instructions are simply a guide for how I personally managed to fix this annoyance. Use at your own risk.

First off, you may need to enable the "Source code" repository. To do this in Ubuntu, press the Super/Windows key and type "Source". Open the "Software Sources" application from the results. Check the box before "Source code", then click close.

From Terminal:

mkdir ~/Desktop/nautilus-mod
cd ~/Desktop/nautilus-mod
sudo apt-get update
apt-get source nautilus
sudo apt-get build-dep nautilus
cd ~/Desktop/nautilus-mod/nautilus-3*

gedit src/nautilus-toolbar.c

Now, scroll down to line 132 or do a "find" for

gtk_toolbar_insert (GTK_TOOLBAR (self->priv->toolbar), > item, 0)

and change the 0 to a 2. So change the original line

from:

gtk_toolbar_insert (GTK_TOOLBAR (self->priv->toolbar), item,> 0); 

To

gtk_toolbar_insert (GTK_TOOLBAR (self->priv->toolbar), item,> 2); 

When you're done, click save and close Gedit.

Back in Terminal, run the following:

./configure
make
sudo killall nautilus
sudo make install
nautilus &

At this point, I would actually recommend logging out and back in or just restarting.

To undo the changes and revert back to stock Nautilus, you can either change the "2" back to a "0", re-make and re-install, or you can simply run:

sudo apt-get --reinstall install nautilus 

You might want to remove the required dev packages also, but be careful not to remove something that may have already been there and is needed.

share|improve this answer
add comment

At the moment there is not solution for this issue, its not a theme related setting that can be changed easily.

If you feel this is greatly affecting you, you may report a bug and suggest the change or the lack of that kind of settings directly to the gnome developers.

Has an option you can try to use another file manager that has the navigation buttons on the left side, I recommend you marlin the ElementaryOS file manager.

enter image description here

Bar can be customized

enter image description here

You can install it by adding the marlin official PPA

sudo add-apt-repository ppa:marlin-devs/marlin-daily/daily && sudo apt-get update

Install marlin using this command

sudo apt-get install marlin

After that launch in your dash or by pressing AltF2 and typing marlin.

Be aware that marlin is still under development and should be used with some caution.

share|improve this answer
    
To the phantom downvoters: This is a perfectly valid answer. –  jrg Nov 12 '11 at 0:38
    
I'll contact the GNOME developers, but int he meantime I'll just stick to nautilus. I knew about marlin but since its still in development I prefer not to use it to avoid any problems. Thank you for your help. –  DeoxNa Nov 12 '11 at 20:28
    
When you do drop a link, maybe more people would like to subscribe to it making your request / bug report more visible. –  Bruno Pereira Nov 13 '11 at 9:13
    
Link's been added to the original post, I would of posted it before but I couldn't find time to do so. –  DeoxNa Nov 18 '11 at 2:42
add comment

By far the easiest answer:

gconftool-2 -t str --set /apps/metacity/general/button_layout "menu:minimize,maximize,close"
share|improve this answer
1  
I think he's asking how to move the navigation arrows to the left. Not the window controls. –  Jo-Erlend Schinstad Jan 18 '12 at 22:51
add comment

There is an Ubuntu Forums post which details how to achieve what you want;

How To Move Nautilus 3+ Back & Forward Buttons to the Left of the Location Bar

Essentially follow these steps

First off, you may need to enable the "Source code" repository. To do this in Ubuntu, press the Super/Windows key and type "Source". Open the "Software Sources" application from the results. Check the box before "Source code", then click close.

mkdir ~/Desktop/nautilus-mod

cd ~/Desktop/nautilus-mod

sudo apt-get update

apt-get source nautilus

sudo apt-get build-dep nautilus

cd ~/Desktop/nautilus-mod/nautilus-3*

gedit src/nautilus-toolbar.c

Now, scroll down to line 132 or do a "find" for "gtk_toolbar_insert (GTK_TOOLBAR (self->priv->toolbar), item, 0)" and change the "0" to a "2".

So change the original line from: gtk_toolbar_insert (GTK_TOOLBAR (self->priv->toolbar), item, 0);

To: gtk_toolbar_insert (GTK_TOOLBAR (self->priv->toolbar), item, 2);

When you're done, click save and close Gedit.

Back in Terminal, run the following:

./configure --prefix=/usr

make

sudo killall nautilus

sudo make install

nautilus &

At this point, I would actually recommend logging out and back in or just restarting.

To undo the changes and revert back to stock Nautilus, you can either change the "2" back to a "0", re-make and re-install, or you can simply run:

sudo apt-get --reinstall install nautilus

At all times remember the authors disclaimer;

Warning: I am not a professional and am not responsible for anything going wrong. These instructions are simply a guide for how I personally managed to fix this annoyance. Use at your own risk.

share|improve this answer
add comment

Open your Terminal:

sudo apt-get install gconf-editor

Run gconf:

gconf-editor

Go to “apps/metacity/general/”. Find “button_layout” and update the value to:

menu:minimize,maximize,close

Save, logout and login. Voila !

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.