Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I switched from Unity to Gnome Shell in Ubuntu. Now Chrome has the buttons on the left side, but I want them on the right. How can I fix this without switching to the system titlebar?

I also tried gconf-editor and modifying apps>metacity>general>button_layout, but that doesn't make any difference.

share|improve this question
add comment

4 Answers

up vote 11 down vote accepted

That works for me in Gnome Shell and Chrome 15.0.874.120. Try from the command line:

gconftool-2 --set /apps/metacity/general/button_layout --type string ":minimize,maximize,close"
share|improve this answer
    
Thanks. That worked. –  Asa Ayers Nov 13 '11 at 9:39
add comment

Won't let me add a comment to the chosen answer

if you use

gconftool-2 --set /apps/metacity/general/button_layout --type string ":minimize,maximize,close"

You'll keep all the buttons

share|improve this answer
add comment

You alternatively make chrome use the system theme in options under appearance. This is for people who are still searching for how to make chrome take on a more native appearance.

share|improve this answer
add comment

Works only for all metacity windows, but not for the integrated in new Chrome buttons... To make it work, just need to check the option to see title bar in the browser's settings..

share|improve this answer
1  
It works for me with the integrated buttons. –  Asa Ayers Mar 21 '12 at 14:35
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.