Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Various icons from launcher are missing. The first one is from Home folder menu the second from Terminal the last one from Desktop Switcher. This happened after I upgraded to 11.10 from 11.04. I have created a New (Untitled Folder) folder in my desktop and the icon is missing too. The same occurs in System Settings menu too. Some icons like Appearance, Keyboard Layout are missing too. Sorry but I can't post a screenshot due to my reputation.

Any suggestions?

share|improve this question

This can happen if you used a different Icon theme before upgrading for example Faenza Icon Theme.

To revert to one of the original Ubuntu-mono Icon themes, you need to install gnome-tweak-tool to do it in a simple way. After installation start the tool go to Theme, and change the Icon setting from the dropdown menu back to the original theme ubuntu-mono-light/dark. In case you want to have back the old theme reinstall it as you did the first time you used it.

share|improve this answer
Τhank you Veet Moha!!! It worked!!! Sadly I can't vote up due to my bad reputation :) – Giannis Rizos Nov 17 '11 at 11:54
@GiannisRizos: I will upvote this answer for you but plz, if this answer solved your problem, accept the answer first – binW Nov 27 '11 at 9:58
This didn't work for me, but it seems sudo apt-get install --reinstall unity-asset-pool and a reboot worked. – l0b0 Jun 22 '12 at 17:24
you can also use the myunity tool which does not require as many dependencies as gnome-tweak-tool : – Tom Carchrae Dec 11 '13 at 18:48

Elaborating what was said in above answers. What worked for me was that I had used MyUnity to tweak the GUI, namely the "theme" section for "icons", setting this back to default (several worked actually) fixed the problem for me.

share|improve this answer


sudo unity --distro

that bug made me crazy, too!

If it didn't resolve, I remember that I deleted some .configuration file (you can see them in the /home, just press Ctrl+H), but now I didn't remember the name of the correct one. unity -h let you see some different options.

share|improve this answer
That didn't work for me. I tried to delete various configuration files from my home directory but it didn't work either. :( – Giannis Rizos Nov 14 '11 at 15:43

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.