Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've seen this problem reported under several questions, but I haven't been able to resolve any of it so I thought I'd bring it all in under one umbrella.

I started a new job and was given a Dell Precision M6400 laptop with Nvidia Quadro FX 2700M graphics card. It had a previous version of Ubuntu on it, but nobody had any passwords for it so I wiped the drive and did a fresh install of 11.10 from scratch. I didn't do any updates during installation, preferring to do them after boot. Updates ran fine and the system works... except Unity is in 2D mode.

System Settings -> Additional Drivers shows that Nvidia-Current is active but not in use. System Settings -> System Info shows Graphics Driver Unknown, Experience Standard

Nvidia X Server Settings is installed and working, re-writing the xorg.conf did nothing.

/usr/lib/nux/unity_support_test -p

OpenGL vendor string:   NVIDIA Corporation

OpenGL renderer string: Quadro FX 2700M/PCI/SSE2

OpenGL version string:  3.3.0 NVIDIA 285.05.09

Not software rendered:    yes

Not blacklisted:          yes

GLX fbconfig:             yes

GLX texture from pixmap:  yes

GL npot or rect textures: yes

GL vertex program:        yes

GL fragment program:      yes

GL vertex buffer object:  yes

GL framebuffer object:    yes

GL version is 1.4+:       yes

Unity 3D supported:       yes

One suggestion was to do a sudo apt-get --purge remove nvidia* and that resulted in a scrambled screen on boot and a non-bootable installation. Pressing the Delete key on boot allowed me to access the recovery console and do a sudo apt-get install nvidia-current, which brought me back to a working, bootable system.

Another suggestion was to edit /etc/default/grub and change the line reading GRUB_CMDLINE_LINUX_DEFAULT="quiet splash" to read GRUB_CMDLINE_LINUX_DEFAULT="quiet splash vmalloc=192MB" thus allocating more video RAM.

I did that, followed by a sudo update-grub and a re-boot. No change.

Created a brand new standard user and logged on with that account, no change.

share|improve this question
    
other than the listings in "system settings", how can you tell that it's running in 2d mode? Everything else you posted says that the 3d should be fine... –  ImaginaryRobots Nov 11 '11 at 17:26

1 Answer 1

The two things that led me to think I was running 2D instead of 3D were the graphics unknown and the nvidia-current active but not being used.

However now that I see this thread comparing the alt-tab switcher in both systems it seems it actually IS running in 3D mode even though everything is saying it's off.

http://ubuntuforums.org/showthread.php?p=11442860

Weird.

share|improve this answer
1  
Try this question and answer to confirm what you are running: askubuntu.com/questions/62001/am-i-using-unity-or-unity-2d –  fossfreedom Nov 11 '11 at 18:58
    
based on all that, it seems like the system settings tools just aren't able to detect your video driver somehow. The additional drivers tool might have a bug in it. –  ImaginaryRobots Nov 11 '11 at 19:12

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.