Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm using Ubuntu 11.10 (unity 4.24.0) and I can't seem to focus the desktop. For example, if I press Mod4+D, the window I had opened stays focused, but the image is see is my wallpaper.

If I minimize all windows one by one, the last window I minimize is still focused when the desktop finally appears.

This means I can't add desktop icons, nor use the mouse in it.

I thought about reporting a bug, but everything works fine on other computers with the latest version of Ubuntu I've used, so I'm wondering about what's happening.

Before, when I pressed Mod4+D, the Unity Top Menu would say "Desktop - File Edit ..." and I could use the desktop properly.

Thanks in advance!

share|improve this question

3 Answers 3

I think you need to have Nautilus manage the desktop, there's no standard option for that as far as I can tell, but if you install gnome-tweak-tool and open it up, under the desktop tab there's an option to have the file manager manage the desktop, I'm pretty sure that'll do what you want.

share|improve this answer

Not sure what you've got going - in 11.10 Mod4(super)+D does nothing, the show desktop binding is Ctrl+Alt+D

Open a terminal & try this

gsettings set  org.gnome.desktop.background show-desktop-icons true
share|improve this answer
    
Mod4+D is my custom shortcut, sorry. And that worked, thanks! –  user25119 Nov 11 '11 at 16:50

Mod4+d isn't the default key combo. I think you know this and one of the other answers will help more, but just in case:

  1. Warning: CCSM is in universe and not shipped by default for a reason, it can be flaky, so be careful in there, it can break things, if you find yourself with a broken window manager, see this question to reset your configuration.
  2. Install the CompizConfig Settings Manager (CCSM).
  3. Run CompizConfig Settings Manager.
  4. Go to General Settings.
  5. Select the Key Bindings tab.
  6. Click the button (showing the current keybinding) next to Show Desktop and select your desired key combo.

In 11.10, I have mine set to Super+d and when I hit it, the top panel says "Desktop". I can use the arrow keys to move between folders on my desktop.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.