Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have had German as my main language about a year ago. Later I changed it to English. Most parts of the system accepted the change.

The notable exceptions are the package descriptions, which remain in German for some packages.

You can see in the image (apt-cache and software-center), that while some descriptions are in English, some have remained in German. So the question is: how do I reset this? I guess that there is somewhere a description cache that needs to be told that it should update all descriptions?

screenshots of apt-cache and software-center

EDIT: As asked: the output of some language related commands:

$ cat /etc/default/locale
LANG="en_US.UTF-8"

$ apt-config dump | grep Lang
Acquire::Languages "";
Acquire::Languages:: "de_DE";
Acquire::Languages:: "de";
Acquire::Languages:: "en";
Acquire::Languages:: "none";

$ locale
LANG=de_DE.UTF-8
LANGUAGE=en
LC_CTYPE="de_DE.UTF-8"
LC_NUMERIC="de_DE.UTF-8"
LC_TIME="de_DE.UTF-8"
LC_COLLATE="de_DE.UTF-8"
LC_MONETARY="de_DE.UTF-8"
LC_MESSAGES="de_DE.UTF-8"
LC_PAPER="de_DE.UTF-8"
LC_NAME="de_DE.UTF-8"
LC_ADDRESS="de_DE.UTF-8"
LC_TELEPHONE="de_DE.UTF-8"
LC_MEASUREMENT="de_DE.UTF-8"
LC_IDENTIFICATION="de_DE.UTF-8"
LC_ALL=

As a note: I'm not sure what each entry means, but some of the de_DE.UTF-8 are probably ok, since I do want paper-sizes, monetary, time, etc. in standard German formats.

share|improve this question
    
Can you show the output of: cat /etc/default/locale, apt-config dump | grep Lang, and finally locale, please? –  enzotib Nov 11 '11 at 10:46
    
sure, output is added to the question. –  xubuntix Nov 11 '11 at 10:51
add comment

2 Answers 2

up vote 2 down vote accepted

I have done some tests, and I can say that the locale variable that determine the APT behavior about translations to download is LC_MESSAGES, as expected.

In fact, if you do the following commands:

export LC_MESSAGES=en_US.UTF-8
sudo rm -rf /var/lib/apt/lists/*
sudo apt-get update

you should come up to english translations only.

To permanently have that variable set to english, you should put the lines

export LC_MESSAGES=en_US.UTF-8

in your ~/.profile.

Take also into account that modifying that variable could influence the behavior of other applications too, because they use that setting to decide with which language to talk to the user. If you want to have package description in english without modifying the LC_MESSAGES variable, you can create a file in the /etc/apt/apt.conf.d/ directory, say you name it 20language, and put the following content in it

Acquire::Languages "en";

after done that, and before updating the repository cache, remove the old cache with

sudo rm -rf /var/lib/apt/lists/*
share|improve this answer
add comment

The first 3 lines of code in enzotib's answer did not solve the problem. I did not proceed further because I'm too new to Linux and it looked like a solution with probable conflicts to me. What did fix this problem for me was the following code:

sudo apt-get --reinstall install software-center

I've read that just like ubuntu software center, update manager's language is affected too, so I also run

sudo apt-get --reinstall install update-manager

just in case.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.