Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

When I would like to pause/play my radiotray application used the required shortcut the next window can been seen:

not expected window

How can I solve this problem? Sometimes the shortcut works, but I do not know why.

share|improve this question
    
I think this is a bug in Ubuntu 11.10: bugs.launchpad.net/unity/+bug/860600 :( –  Regisz Nov 12 '11 at 12:08

2 Answers 2

Your media keys are likely working fine. However, they control your default music player which—judging by the overlay—isn't launched, or has nothing in the playlist.

enter image description here

RadioTray can't be added as the default music player, unfortunately, because it doesn't support the MPRIS API Ubuntu uses for extra-application media controls. The status of that issue can be tracked here, it seems.

share|improve this answer
    
I think no this is the problem. My default 'Music' is VLC, but it can not be play/pause with default shortcut. Moreover sometimes the shortcut works (I has written already this in the question description :) ). –  Regisz Nov 11 '11 at 11:38
    
@Regisz Try opening VLC with a few songs and use the keys. –  Jjed Nov 11 '11 at 11:42
1  
hm, very interesting: If I start Banshee, then I can use default shortcut-key to play/pause the RadioTray application :). But if I start a media in Banshee then the shortcut-key manages both application. –  Regisz Nov 11 '11 at 12:06
    
I tried your idea, but VLC did not respond. –  Regisz Nov 11 '11 at 12:08

@Regisz: Same here, I have Audacious as my default media player, but it doesn't work with multimedia buttons on my wireless keyboard or any keys on my headset. As soon as I start Rhytmbox while having Audacious still running, I can "control" both media players with a single Play/Pause button somehow.

Anyway, this question could be a duplicate of:
Can I map the media player function keys to a media player other than Totem?

BTW, I've just found out that the new version of Audacious has own plugin for multimedia keys, so my similar issue has been resolved with it. Now it works!

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.