Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I googled the problem and found this link:

Unfortunately when I input the command into the terminal I get this message:

bash: /etc/modprobe.d/blacklist.conf: Permission denied

I don't know of any alternative solutions, but advice is appreciated.

share|improve this question
Update the Kernel. – Uri Herrera Feb 26 '12 at 18:27
What is not working ? We see a "wlan0", please update your question to describe your problem. – bodhi.zazen Feb 26 '12 at 20:17
sorry if i wasn't clear. my network control panel says that wireless is not available. i can't set the toggle to "on" for wireless (it just flips back immediately to off). there are wifi networks in my house, but since i can't turn wireless on, i can't log on to them. – well i'll be Feb 26 '12 at 21:57
it does show a hardware address for the wireless, but says unavailable. when i grep the driver (ath5k) it seems to be there:ath5k 145100 0 ath 19387 1 ath5k mac80211 393421 1 ath5k cfg80211 172427 3 ath5k,ath,mac80211 – well i'll be Feb 26 '12 at 22:00
Kernel is updated. – well i'll be Feb 27 '12 at 1:11

If you are in Unity or Gnome from a terminal write: sudo gedit /etc/modprobe.d/blacklist.conf. Then go to the bottom and add: blacklist acer_wmi. I hope the solution works for you because adding it did nothing for me but it is still worth a try. Roman

share|improve this answer

Answer to Roman

Maby this may help you. I've searched for the same thing but it seamed that I had another problem (my wireless was 'unhandled') and I found this solution mostly by chance really.

"Wireless Networks device not managed"

Good luck :)

share|improve this answer

Refer to How do I install a driver for an Atheros AR9285? for more info. I had a Compaq with the same problem and followed the directions at the bottom and the problem was solved. You have to add the blacklist acer_wmi to the bottom of the file /etc/modprobe.d/blacklist.confthe reboot. As I had the CQ60, I don't know if it will work perfectly, but I think it should.

Quoted from the above site - "I have just solved the wireless problem on Lenovo B560. However, I'm a beginner into Linux, and didn't immediately figure that blacklist acer_wmi can only be added by running the command:

gksu gedit /etc/modprobe.d/blacklist.conf

Hope this helps.

share|improve this answer
Please don't link to existing answers on this site, but flag the question as a duplicate. – Fabby Oct 6 '15 at 10:03

my network control panel says that wireless is not available. i can't set the toggle to "on" for wireless (it just flips back immediately to off).

After installing the same Atheros card (PCI Express version on Acer Aspire One) I saw the exact same behaviour. Switching the two antenna cables connected to the card (one black, one white) solved the issue for me. White cable goes on the connector marked MAIN, black on AUX. No need to blacklist anything nor install any (mad) drivers ;)

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.