Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I don't understand how to open and use Syslinux so that it can create a bootable USB. I am not familiar with a lot of the language on the standard answers, so less tech is better. I downloaded version 3.11 and opened and extracted it with Bitzipper: that works. The procedure I am trying to follow says this:

"Download Syslinux-this is a utility that will make the FAT32 partition of your USB stick bootable. With the Windows Command Prompt, cd over to the "win32" subdirectory of the Syslinux directory you downloaded and type the following, where "F:" is the drive letter for the TYPE11 partition on your USB stick:

syslinux -ma F:"

I can't find a win32 subdirectory, and I can't get the syslinux.exe file to run. Is there a different version of syslinux I need to find? thanks, DM

share|improve this question
add comment

1 Answer 1

Do you specifically need to make a USB stick bootable, or are you trying to create a bootable Ubuntu Live USB?

If all you want is a bootable Ubuntu USB, you may find unetbootin friendlier, and it takes care of making the stick bootable for you:

http://unetbootin.sourceforge.net/

If you need to make the USB stick bootable for another purpose and really need syslinux, it looks like the instructions you followed are for newer versions, since 3.11 looks to be quite a bit outdated. You may want to download Syslinux 4.04 from here:

http://www.kernel.org/pub/linux/utils/boot/syslinux/

when you unzip it you'll indeed see the win32 directory your instructions point to, with a syslinux.exe binary.

Give it a try and let me know if either of these solutions work for you.

share|improve this answer
    
Thanks! The new one has the win32 file. I will try it. –  DMO Nov 11 '11 at 16:43
    
What happens with the syslinux 4.04 is that I extract it with bitzipper, open the win32 folder, and try to run the syslinux program inside that. The ms-dos 'command' screen blinks and then disappears. Same happened when I tried this on a machine running obuntu (as when I tried it on this machine running windows). I am obviously ignorant of something here. –  DMO Nov 11 '11 at 20:58
    
Open a command prompt and change to the win32 directory, and type "syslinux -ma F:". Maybe then you'll get a useful error message. Syslinux is meant to be used from the command prompt, double-clicking on it is not going to be useful. If you do prefer a GUI program as opposed to a command-line utility, I strongly suggest you use unetbootin as it may be easier to use. –  roadmr Nov 11 '11 at 21:17
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.