Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I tried downloading the driver from dell, but their updates only go up to Ubuntu 9.04....I don't know if that is the issue.

I downloaded it and unzipped, went to install it then it asked for an administrative password. I entered what I use to log onto Ubuntu but it didn't work.

share|improve this question
add comment

1 Answer

I had this same problem when installing the exact same model printer in Ubuntu 11.04. I was able to find a solution at that time through Google, and wrote it down. Follow these steps:

  1. Open a terminal window by pressing ctrl-alt-t.

  2. Type: sudo passwd root. This will create a superuser account and establish a password.

  3. Type sudo passwd -u root at the next prompt. This will unlock the superuser account.

When I did this, I chose a different password for the root login, and I used it when running the dell software install shell. It worked. In retrospect, I would probably just use the same password you use whenever you authenticate. The main thing is you have to use the above commands to establish a superuser account.

BTW, I have the exact same printer, and have been unable to print since migrating to Ubuntu 11.10. It now tells me the system can't find the printer. I've run the Dell install several times to no avail. Good luck getting it to work!

(I'm thinking of buying an HP printer since I've heard they're more compatible with Linux).

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.