Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

By default switching between consoles is evaluated by keys CTRL+ALT+Fx (1-6)

How to change these hotkeys? Is there any config file for doing this?

share|improve this question
add comment

2 Answers 2

up vote 3 down vote accepted

Oneiric provides a utility for this. Forgive the cattiness of this post; I can't for the life of me figure out why Ubuntu continues to ship with these keyboard shortcuts enabled in the first place.

Click on the "Dash Home" icon in the top/left end of your toolbar, and search for "keyboard". Open "Keyboard Layout", select the (typically only) layout in the list (why isn't it preselected for you?), then click "Options" and open up "Miscellaneous compatibility options". Select "Special keys (Ctrl+Alt+) handled in a server". Spend the next thirteen seconds thanking the developer who added this little checkbox, and the next ten wondering (again) why the little checkbox isn't checked by default.

In good humor, JB

share|improve this answer
add comment

Those shortcuts are not defined by ubuntu, they are part of the basic linux kernel keyboard drivers. Changing them appears to be possible by following the instructions here:

http://www.linuxjournal.com/article/187

The basics are that you need to create your own custom keymap file, then set up a custom upstart job to load that at boot time. Note that you can make your keyboard completely unusable by doing this, so test it out before setting up the upstart job.

share|improve this answer
    
I'm asking this, because I've noticed that these hotkeys have been changed somehow. Now, if I press ALT+F4 I open the forth console. ( It's everything OK with my CTRL button ) –  Innuendo Nov 10 '11 at 19:10
    
alt-f4 has always been an alternate shortcut for this, but the X11 GUI overrode it to 'close window'. If you're in a virtual console, alt-Fx is expected to switch you to another virtual console. If alt-f4 is switching to a virtual console for you from the GUI, then possibly the GUI shortcut got removed somehow? –  ImaginaryRobots Nov 10 '11 at 19:28
    
OK, i've undestand, i'll research this. alt+f4 is not the only hotkey that works in such a weird way for me ( from gui ) –  Innuendo Nov 10 '11 at 19:33
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.