Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am presently experiencing symptoms as described here:

https://bugs.launchpad.net/ubuntu/+source/apt/+bug/493154

Example:

127-12:42 djh@noneedto ~$ aptitude search chrome
aptitude: error while loading shared libraries: libapt-pkg-libc6.10-6.so.4.8: cannot open shared object file: No such file or directory

127-12:46 djh@noneedto ~$ apt-get -h
The program 'apt-get' is currently not installed.  You can install it by typing:
sudo apt-get install apt
You will have to enable the component called 'main'

So, my thinking, as describe in the bug, is just to download the dpkg for apt. Unfortunately, this is not an easy thing to Google, because usually when people are looking to know about "apt" and "download" and "install" it is "how to use apt-get" ... but wher do I get apt from if it is missing in the first place?

I am running Ubuntu 10.04.3 LTS (lucid)

Update: per mailq's answer, the fix here was:

wget http://archive.ubuntu.com/ubuntu/pool/main/a/apt/apt_0.7.9ubuntu17.3_amd64.deb
sudo dpkg -i apt_0.7.9ubuntu17.3_amd64.deb

If you are fixing this problem, cruise over to http://archive.ubuntu.com/ubuntu/pool/main/a/apt/ and select a package suitable to your system.

share|improve this question

migrated from serverfault.com Nov 10 '11 at 16:43

This question came from our site for professional system and network administrators.

1  
Have you tried running the commands as root, or via sudo? The errors you get are unusual, but unless you can't install things unless are root. If you still can't run apt as root, then you have seriously done something evil on your system. –  Zoredache Nov 9 '11 at 21:14

2 Answers 2

up vote 3 down vote accepted

This question is off-topic!

Download everything you need from: http://de.archive.ubuntu.com/ubuntu/

http://de.archive.ubuntu.com/ubuntu/pool/main/a/apt/ in special

Change "de" to the country code of where you live.

share|improve this answer

Navigate to the aptitude package page on the Ubuntu website (replace ubuntu.com by debian.org if you're on Debian). Pick the right version (lucid) for you. You either need matching, working aptitude and libapt-pkg-* (provided by apt) packages. Follow the download link for your architecture and download the .deb file(s) that you need.

You can also navigate to the package archive on a Ubuntu mirror (Debian mirror) near you. You can find out precisely which package sources your system normally uses by looking in /etc/apt/sources.list and /etc/apt/sources.list.d/*.list on your system. The packages are organized by distribution component (main/restricted/universe/multiverse for Ubuntu, main/contrib/non-free for Debian) and then by source package. For example, look in http://us.archive.ubuntu.com/ubuntu/pool/main/a/apt/ . All the versions carried by the mirror are in the same directory, so make sure you pick the right one for your system. Note that security upgrades live on a separate server.

Once you've downloaded the .deb files, install them by running the dpkg command as root:

sudo dpkg -i /path/to/package.deb
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.