Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

The USB keyboard and mouse worked fine during installation, and works fine until and including the Grub menu, but in the login screen (or recovery menu) it doesn't work at all. I've followed recent instructions for installing 11.04, and I'm booting with one of these Grub settings (normal and recovery boot, respectively):

linux /boot/vmlinuz-2.6.38-12-generic root=/dev/sda2 ro nomodeset xforcevesa quiet splash vt.handoff=7
linux /boot/vmlinuz-2.6.38-12-generic root=/dev/sda2 ro nomodeset xforcevesa single

During boot I see something like this output:

ureadahead terminated with status 5
ureadahead-other terminated with status 5
Automatic bug reporting [...] FAILED
plymouth terminated with status 1

Why are my keyboard and mouse not working?

Tried to install without a separate /var partition to see if that works. Looks like others have fixed the ureadahead issue this way, but it made no difference.

Both mouse and keyboard work when booting from the Live CD. After a chroot /media/[GUID] and grep -i 'error\|warn\|critical\|terminated' /var/log/syslog:

kernel: [    5.731418] EXT3-fs (sda2): error: couldn't mount because of unsupported optional features (240)
kernel: [    5.731578] EXT2-fs (sda2): error: couldn't mount because of unsupported optional features (240)
kernel: [   10.372093] EXT4-fs (sda2): re-mounted. Opts: errors=remount-ro
gdm-binary[507]: WARNING: Unable to load file '/etc/gdm/custom.conf': No such file or directory
init: apport pre-start process (554) terminated with status 1 
init: apport post-stop process (641) terminated with status 1
gdm-binary[507]: WARNING: Unable to find users: no seat-id found
NetworkManager[550]: <warn> bluez error getting default adapter: The name org.bluez was not provided by any .service files
gdm-simple-slave[700]: WARNING: Unable to load file '/etc/gdm/custom.conf': No such file or directory
kernel: [   17.403135] EXT4-fs (sda2): re-mounted. Opts: errors=remount-ro,commit=0
gdm-session-worker[875]: WARNING: Unable to load file '/etc/gdm/custom.conf': No such file or directory
gdm-simple-greeter[873]: Gtk-WARNING: /build/buildd/gtk+2.0-2.24.4/gtk/gtkwidget.c:5687: widget not within a GtkWindow
kernel: [   24.993468] EXT4-fs (sda2): re-mounted. Opts: errors=remount-ro,commit=0
gdm-simple-greeter[873]: WARNING: Unable to load CK history: no seat-id found

More goodies from /var/log/gdm/*:

gdm-simple-greeter[873]: Gtk-WARNING: /build/buildd/gtk+2.0-2.24.4/gtk/gtkwidget.c:5687: widget not within a GtkWindow
Window manager warning: Buggy client sent a _NET_ACTIVE_WINDOW message with a timestamp of 0 for 0x1000034 (Login Wind)
Window manager warning: meta_window_activate called by a pager with a 0 timestamp; the pager needs to be fixed.
gdm-simple-greeter[873]: WARNING: Unable to load CK history: no seat-id found
gnome-settings-daemon: Fatal IO error 11 (Resource temporarily unavailable) on X server :0.
gnome-session: Fatal IO error 11 (Resource temporarily unavailable) on X server :0.
Window manager warning: Fatal IO error 11 (Resource temporarily unavailable) on display ':0'.
gdm-simple-greeter: Fatal IO error 11 (Resource temporarily unavailable) on X server :0.
gnome-power-manager: Fatal IO error 11 (Resource temporarily unavailable) on X server :0.
> Warning:          Type "ONE_LEVEL" has 1 levels, but <RALT> has 2 symbols
Errors from xkbcomp are not fatal to the X server
error setting MTRR (base = 0xd1000000, size = 0x00e00000, type = 1) Invalid argument (22)
gdm-simple-slave[700]: WARNING: Unable to load file '/etc/gdm/custom.conf': No such file or directory
gdm-session-worker[875]: WARNING: Unable to load file '/etc/gdm/custom.conf': No such file or directory

Edit: Filed a bug report.

share|improve this question
    
there is a simple solution to unlocking the keyboard that does not involve a hard reset: CTRL + ALT + F3 may be this should work –  Gaurav_Java Nov 10 '11 at 13:09
    
Virtual terminals don't work either. Tried it already. –  l0b0 Nov 10 '11 at 13:28
    
l0b0: Can you mark this as closed or answer with the bug report link and accept the answer? Thanks! –  justingrif Feb 28 '12 at 4:24
    
@justingrif: It has not been fixed, and it's possible that someone here has a solution, so I think not. –  l0b0 Feb 28 '12 at 7:53
    
This question should instead be filed as a bug report, and as such is off-topic, thanks! How to report a bug. Regards, –  Ringtail Mar 19 '12 at 18:30
add comment

closed as too localized by jrg Mar 19 '12 at 18:56

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

Browse other questions tagged or ask your own question.