Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a A4Tech Pk-635 web cam, and I can view output from web cam in Cheese. Skype is detecting webcam as dev/Video0, but Skype is not generating any output... any ideas?

note: In case any one else also face this, here is a solution to fix this problem and also update skyp launcher, so that you can launch skype as usual.

share|improve this question
    
What happens if you run bash -c 'LD_PRELOAD=/usr/lib/i386-linux-gnu/libv4l/v4l1compat.so skype'??? –  Bruno Pereira Nov 10 '11 at 12:31
    
may be this link will help you out ubuntuforums.org/showthread.php?t=997807&page=3 –  Gaurav_Java Nov 10 '11 at 12:34
    
@brunopereira81 yup it started working as expected... –  Usman Masood Nov 10 '11 at 13:16
    
possible duplicate of QuickCam E 3500 working from Cheese, but not Skype –  Bruno Pereira Nov 10 '11 at 14:04

2 Answers 2

up vote 1 down vote accepted

Change the skype launcher from skype to bash -c 'LD_PRELOAD=/usr/lib/i386-linux-gnu/libv4l/v4l1compat.so skype'.

share|improve this answer
    
any possible reason? –  Usman Masood Nov 10 '11 at 15:09
    
Yeah, skype is not loading the video4linux library in 11.10, your not the only one as you can see from the Possible duplicate ticket under your question. Its just happening at the moment, nothing you have done or can do to solve it except wait ;) gl –  Bruno Pereira Nov 10 '11 at 15:45

if you have Skype 4.2 installed (on Ubuntu 12.04 or latest, provided you've installed ia32-libs from Synaptic) don't open Skype from the launcher, just open your terminal and paste: LD_PRELOAD=/usr/lib/i386-linux-gnu/libv4l/v4l1compat.so /usr/bin/skype and see how your camera will work just fine on Skype.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.