Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I ran:

unity --reset

And got:

WARNING: Unity currently default profile, so switching to metacity while resetting the values

(metacity:3086): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",

(metacity:3086): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",

(metacity:3086): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",

(metacity:3086): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",
Checking if settings need to be migrated ...no
Checking if internal files need to be migrated ...no
Backend     : gconf
Integration : true
Profile     : unity
Adding plugins
Skipping upgrade com.canonical.unity.unity.01.upgrade
Skipping upgrade com.canonical.unity.unity.02.upgrade
Initializing core options...done
Initializing bailer options...done
Initializing detection options...done
Initializing composite options...done
Xlib:  extension "GLX" missing on display ":0".
Xlib:  extension "GLX" missing on display ":0".
Xlib:  extension "GLX" missing on display ":0".
Compiz (opengl) - Fatal: glXCreateContext failed
Compiz (bailer) - Info: Ensuring a shell for your session
abdurahim@abdu-1:~$ 
(metacity:3151): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",

(metacity:3151): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",

(metacity:3151): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",

(metacity:3151): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",

Before being returned to the prompt.

share|improve this question
    
What graphics card do you have? –  RolandiXor Nov 12 '11 at 19:09
    
The gtk warnings can be removed installing gtk2-engines-pixbuf as explained in this answer. –  jcollado Feb 20 '12 at 7:37

1 Answer 1

From the looks of things, it seems like your 3D support is not enabled.

Somethings you can try are:

  • Reboot the system.
  • Run jockey-gtk and install the drivers for your card.
  • Ensure you have all updates installed.
share|improve this answer
    
i ran jockey-gtk and installed the driver all updates are installed and ran unity --reset and getting the same error message again. my laptop is lenovo ideapad Z470 –  Akrahim Nov 11 '11 at 5:53
    
@Akrahim can you add that info to your question? –  RolandiXor Nov 11 '11 at 14:05

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.