Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am using Ubuntu 11.10 and following instructions mentioned here to install Rabbit VCS.

I added the PPA properly, did a sudo apt-get update and ran

sudo apt-get install rabbitvcs-core rabbitvcs-nautilus rabbitvcs-thunar rabbitvcs-gedit rabbitvcs-cli

There were dependency issues and I googled a bit and found out that I need to install RabbitVCS only for nautilus as that is the default file manager for Ubuntu.

So I ran the install commands separately for rabbitvcs-core, rabbitvcs-gedit and rabbitvcs-cli. Now my understanding is that those are installed properly.

However when I run the install command for rabbitvcs-nautilus, I still get a dependency issue.

ranhiru@ranhiru-HP-HDX16-NoteBook-PC:~$ sudo apt-get install rabbitvcs-nautilus
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 rabbitvcs-nautilus : Depends: nautilus (< 1:3.0~) but 1:3.2.1-0ubuntu2 is to be installed
                      Depends: python-nautilus (< 1.0~) but 1.0-0ubuntu2 is to be installed
E: Unable to correct problems, you have held broken packages.

How do I solve this?

share|improve this question
    
possible duplicate of Rabbit VCS stopped working after upgrade to 11.10 –  Jorge Castro Nov 10 '11 at 4:37
add comment

3 Answers

up vote 8 down vote accepted

If you've used the PPA (ppa:rabbitvcs/ppa) and want to install the version that supports GNOME3/Nautilus 3, install "rabbitvcs-nautilus3" instead of "rabbitvcs-nautilus".

Well, that fixes the installation issues. However, for me it still doesn't show up on right click.

Edit: after upgrading to the latest Nautilus from the Ubuntu 11.10 proposed repository, the right click menu finally works!

share|improve this answer
    
hey Andrew, after you've checked the pre-released proposed updates you had to do something else also ? I checked the updates available but I don't see anything related to nautilus. thanks. –  misterjinx Nov 23 '11 at 18:29
    
nevermind, it showed up after a restart, the only thing is that the icons are not visible under the default ambiance theme :) –  misterjinx Nov 23 '11 at 18:57
    
+1 ... your answer solved my problem too... –  iammilind Nov 26 '11 at 6:58
    
You an get the icons to show up in the menu by using GNOME Tweak Tool, on the Themes tab, enable "Menus have icons" and "Buttons have icons". –  Alin Andrei Dec 7 '11 at 19:45
add comment

The error message is telling you that the packages in the repositories are newer then what RabbitVCS requires, i.e. it can't work with the new Nautilus from Gnome 3

UPDATE: Actually, if you have a look at RabbitVCS site, you'll see that release 0.15 adds support for Nautilus 3.0 - however, the version in Ubuntu repositories is 0.13

The site also contains instructions on how to install the recent version from a tarball.

share|improve this answer
    
Yes I am using Ubuntu 11.10. So there's no way I can get Rabbit-VCS to install on 11.10 ? :O And I don't mind installing an older version of Nautilus or GNOME for that matter (Pardon me for my ignorance if those are impossible to do) if I can get this to work. I am so much used to tortoise-svn in Windows and I've being told that Rabbit-SVN shares so much in similar with tortoise-svn. –  Ranhiru Cooray Nov 10 '11 at 4:36
1  
I've updated my answer. Also, I can't resist mentioning that many people are perfectly comfortable with command-line VCS clients, so you just might give it a try :) –  Sergey Nov 10 '11 at 4:45
1  
I am keeping command-line VCS as my last resort :D Sorry but I was spoilt by Windows! –  Ranhiru Cooray Nov 10 '11 at 4:49
add comment

Run the following command in a terminal:

sudo apt-get install rabbitvcs-core rabbitvcs-nautilus3 rabbitvcs-thunar rabbitvcs-gedit rabbitvcs-cli
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.