Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

That's my problem, I can not turn on vsync (or vertical synchronization) in gnome shell, so that videos are "choppy" vertically. I must say that I have a HD integrated graphics intel sandy bridge, in ubuntu with nvidia card is easily activated from the nvidia control panel. as I can do the same in intel? It also clarifies that I can enable compiz vsync from ccsm, but I find nothing in shell

share|improve this question
1  
I don't have an answer to your question, but ccsm is for compiz, and gnome-shell does not use compiz so it will be of no use to you. – zookalicious Nov 10 '11 at 22:45

Intel driver has a good option for tear free rendering:

sudo nano /etc/X11/xorg.conf

under the Section device which use intel driver add the following option:

Option "TearFree" "true"

If you do not have the xorg.conf file you can easy generate them for you using nvidia-settings or using Xorg

Look at this

I hope it helped you.

share|improve this answer

You should know about X.Org Server.

You can configure xorg to enable or disable vsync. You can define modeline without vsync: https://wiki.ubuntu.com/X/Config/Resolution#Adding_undetected_resolutions

Maybe there are also Options for vsync (so you can change vsync for all modes) but I'm not sure about this.

Also make sure that you have vaapi enabled and libva installed

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.