Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I use ntpd to set the time on my server to GMT and it works however it always sets the time 12 hours ahead.

It says it is GMT and it doesn't give any errors when I run ntpd.

Any ideas to fix this?

EDIT: Just ran this:

$ sudo ntpd -g -q

ntpd: time set -50404.385760s

$ date

Thu Nov 10 17:43:32 GMT 2011

It seems to have corrected itself

But then:

$ sudo ntpd

sudo: timestamp too far in the future: Nov 11 07:43:21 2011

$ date

Fri Nov 11 07:45:13 GMT 2011

share|improve this question

closed as too localized by jrg Feb 28 '12 at 13:44

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

    
What time zone are you in? GMT is the time in Greenwich, England. What is your timezone setting? Try md5sum $(find /usr/share/zoneinfo -type f) | grep $( md5sum /etc/localtime |awk '{print $1}' ) –  waltinator Nov 10 '11 at 0:52
    
All the outputs are GMT locations. I believe the actual server is in France however I set it to GMT on purpose. –  Dan Nov 10 '11 at 17:36
    
This question appears to be abandoned, if you are experiencing a similar issue please ask a new question with details pertaining to your problem. If you feel this question is not abandoned, please flag the question explaining that. :) –  jrg Feb 28 '12 at 13:44

2 Answers 2

Is timezone set up correctly on your machine? You may configure your local timezone using

sudo dpkg-reconfigure tzdata

command (also I bet it should be possble to do that via Ubuntu UI).

share|improve this answer
    
Yeah the timezone is set to GMT. I think the server is actually in France but I am GMT. –  Dan Nov 10 '11 at 17:34

If that doesnt help try in bios changing time.

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.