Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I need help on this.

I want to try using ubuntu so i downloaded the 11.10 version over the net.

Well after the installation my desktop, i have run the the additional drivers. It installed about 70+ items i think and after a while a window pops up and asks me about the radeon driver, something about the 2 options, the propriety drivers i think. I tried installing the 1st one but i got an error, and i tried the 2nd one and i installed it. After installation it asked me to restart. After i restart, i cant see the ubuntu interface anymore.. all i get to see is a black screen with a message moving around saying "Input Not Supported".

So can i ask how can i install the graphics driver for my pc? i want the cool effect of ubuntu.. hehehe

Im a super newbie in using ubuntu so please bear with me:)

share|improve this question
    
The exact same thing happens to me. :( Same card. –  Shiki Nov 27 '11 at 16:20
add comment

3 Answers

First of all, uninstall the proprietary driver to see a desktop again. Press ALT+CTRL+F1, login and type following commands:

  • Removing proprietary driver

    sudo sh /usr/share/ati/fglrx-uninstall.sh
    sudo apt-get remove --purge fglrx fglrx_* fglrx-amdcccle* fglrx-dev*
    
  • Install open-source driver again

    sudo apt-get remove --purge xserver-xorg-video-ati xserver-xorg-video-radeon
    sudo apt-get install xserver-xorg-video-ati
    sudo apt-get install --reinstall libgl1-mesa-glx libgl1-mesa-dri xserver-xorg-core
    
    sudo mv /etc/X11/xorg.conf /etc/X11/xorg.conf.backup
    sudo rm -rf /etc/ati
    

If you receive: "$ E: Internal Error, No file name for libgl1-mesa-dri..."

Change third command above so:

sudo apt-get install --reinstall libgl1-mesa-glx:i386 libgl1-mesa-glx:amd64 libgl1-mesa-dri:i386 libgl1-mesa-dri:amd64 xserver-xorg-core
  • Now reboot your computer with:

    sudo shutdown -r now
    

Now your default open-source driver will be used.

To install newest Catalyst driver, following this step-by-step guide from here:

http://wiki.cchtml.com/index.php/Ubuntu_Oneiric_Installation_Guide

share|improve this answer
    
+1 for the wiki. –  Shiki Nov 27 '11 at 16:23
    
This didn't work. When I start to build a package for Oneiric, I get an error. :( –  Shiki Nov 28 '11 at 18:05
add comment

The Input Not Supported message is most likely from your monitor indicating that the computer is trying to feed it an image which it can't decode. In most cases this means the resolution is too high, though in some cases it's the refresh rate. You should use the shell (Press CTRL+ALT+F1 to get there) to reset the resolution to 1024x768 60Hz. From there you can try increasing your resolution again until it stops working and then go back one. If 1024x768 still doesn't do it, you can try 800x600 60hz, but that's unlikely to be necessary.

Unfortunately I can't give ubuntu related details, but I found a page which should help you. Also of note: To get back to the GUI desktop after you've reset your resolution, use CTRL+ALT+F7.

The page I mentioned: https://wiki.ubuntu.com/X/Config/Resolution#Resetting_an_out-of-range_resolution

share|improve this answer
add comment

Mmm... Your problem is very strange, probably you need to reinstall the ubuntu installation, you can try to enter in text-console (like recovery) mode, selecting it on the grub options (options displayed at the start after boot ubuntu) and if this work, you most log in specifing your username and password, next tray to dowload the official driver, typing the next commands:

x86/x64:

If this not work, you must reinstall ubuntu completly, and before to logged in, download and install manualy the package described up (driver).

Finaly, I apologize for my bad english, i'm learning it.

share|improve this answer
1  
This guide to install proprietary driver is not correct and can cause errors. Simply reinstall is not a solution and would lead to the same error as above described. –  Steven Peter Beer Nov 9 '11 at 23:06
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.