Sign up ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

I'm trying to write Arabic in the terminal app but it does not recognize right-to-left text and does not bind the Arabic letters together as it should.

I tried this solution but it did not work.

Are there any plans to implement Arabic support in the gnome terminal? KDE Konsole terminal works without any problems.

share|improve this question
What happened when you tried – N.N. Nov 19 '11 at 10:06
why do you need write Arabic in the terminal and why do you want it right to left ??? – Black Block Nov 19 '11 at 23:24
FYI: Arabic is normally written right to left. As are several others languages, with old Hebrew even switching between right to left and left to right. Traditional Japanese writing start from the top-right of page and goes down in a column, with the next 'line' of glyphs to the right. That also gives them books that are read from the right cover, turning pages to left, until the end of the book (Western front cover) is reached. – david6 Nov 22 '11 at 5:06
Do you need both left to right and right to left, during any given session? Are you using terminal emulation (escape sequences, full-screen, field layout), or is this ONLY for command line? – david6 Nov 22 '11 at 5:09
@Naruto for me, I need the Arabic support because I use a treminal IRC client and joining an Arabic channel would show distorted words in the client. Not sure about him. – Suhaib Nov 26 '12 at 5:24

3 Answers 3

try this: sudo apt-get install libfribidi0 libfribidi-dev, install THIS package, then vim /usr/share/applications/gnome-terminal.desktop and add this code to the document:

share|improve this answer
In Ubuntu 13.04, I installed those packages but can find bicon.bin anywhere... – Ba7a7chy Apr 30 '13 at 19:01
I want to get fribidi working on Linux Suse. I have installed Fribidi, following the installation man in its official website, however I don't see a change in terminal. And trying zypper install libfribidi0 I get the error: Loading repository data... Reading installed packages... 'libfribidi0' not found in package names. Trying capabilities. No provider of 'libfribidi' found. Resolving package dependencies. Have been searching and not getting a single result. What packages am I supposed to have? – Neeku Jun 30 '14 at 12:05

For Ubuntu 64 bit, you would need to download This package

instead. I guess you were having a dependency problem. You would need also to install the apps stated above with this command.

sudo apt-get install libfribidi0 libfribidi-dev

Hope that this could help

share|improve this answer

No, there is no plans to implement RTL support in gnome-terminal or any terminal depends on vte as the case of synaptic installation terminal.

  • You may proxy your command through fribidi command to make bidi & basic shaping of Arabic.
  • You may also use konsole (KDE) or mlterm that had implemented a partial support for Unicode bidi and shaping.

Currently, there is no correct way to implement those Unicode algorithms for the consoles. (Those implementions in konsole & mlterm are kind of workaround)

Here is a portion from a Behdad Esfahbod's post, he is the main developer of HarfBuzz (hb for short, an OpenType text shaping engine)

Terminal emulators with support for complex text are very weird hybrids. On the one hand terminal emulators have to lay text out in a predefined grid in a predefined way, which is in conflict with many aspects and requirements of complex text, on the other hand users demand support for complex text in their terminals. It gets uglier when you think about bidirectional text, say, inside a console text editor. Nonetheless, it is fair to say that such hybrids do not put any new demands on the shaping engine. gnome-terminal currently has no support for complex text other than combining marks. Konsole has bidirectional text support. Apple's Terminal App has at least bidi support as well as Arabic shaping support, not sure about other complex text. Update (Jan 18, 2010): The terminal mode (term and ansi-term) in recent versions of Emacs can render complex text, including Indic.

Source: State of Text Rendering

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.