Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I just installed nx-server on a fresh installation of Ubuntu 11.10. I've also followed the instructions as in Using NX with Unity in 11.10 to specify the session I want to be loaded.

It works all right, and I can play with unity-2d or with gnome-classic by just changing the setting of the nx-client.

There is just one glitch remaining, that is that, regardless of the session launched or the theme chosen in system settings, the gtk controls are un-themed, and are just plain ugly. It's like when gnome-settings-daemon is not running if you know what I mean (yes I checked it was running). The picture posted in the question before mentioned (although showing a different problem) explains it all.

Any possible fix?

share|improve this question

1 Answer 1

up vote 0 down vote accepted

I haven't used Nomachine NX in quite a few years, but I can confirm that X2go works, if you're willing to give another NX-solution a try. X2go is quite nice, with PulseAudio support and everything.

I do remember a similar issue a few years ago with FreeNX. Back then, if I remember correctly, it had something to do with libxklavier, if you want a starting point.

share|improve this answer
    
Looks like a known bug, hence I'll accept this answer. –  ostefano Dec 5 '11 at 12:41

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.