Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Good evening, I have a problem to eliminate the annoying "tearing" of my current video card intel HD 3000 (Sandy Bridge CPU). Installing Ubuntu 10.11 (AMD64) the bug is now known (but does not seem resolved) is solved using unity - compiz (the solution is here: Screen tearing in 11.10 with intel graphics 11-10-with-intel-graphics), but I have no solutions for the Gnome Shell. thanks

share|improve this question

4 Answers 4

"You should not experience tearing if you disable compositing and use gl or vaapi output. Tearing still happens with xv/x11 due to vsync not working properly on Sandy Bridge yet, even with compositing disabled."

I confirm that this workaround works on my system with Intel/ATI Hybrid graphics, using Intel graphics as active. I'm in KDE, before playing video I will switch off KDE compositing (Alt+Shift+F2) then play video using mplayer with gl output. No tearing at all! :-) Finally, I can watch movies in great shape on my 32" HDMI TV ^_^

Using VLC still tears, because when with VLC-GLX the video is corrupted, and with XV there's still video tearing even with compositing disabled.

https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-video-intel/+bug/755841/comments/101

share|improve this answer

As Eugeni Dodonov said (Intel Open source technology center member):

[...] when tearing free playback will be possible on Sandy Bridge?

You are hitting the unfamous bug https://bugs.freedesktop.org/show_bug.cgi?id=37686 . There is no fix for this at the moment, but I expect it to get fixed at some point.

Meanwhile, you can play videos without tearing on Sandy Bridge if you use GL or VAAPI video outputs and disable compositing (or use a compositor which plays fine with that). The bug itself have some tricks which you can try to get it working. But for real fix, no, it is not there yet, sorry.

Source (2012/01/13): http://phoronix.com/forums/showthread.php?68199-Intel-Wants-YOUR-Linux-Questions-Feedback&p=246801#post246801

On the other hand, if you've hit by this bug then you should install the latest kernel version, as of 2012 January the 3.2.1 one. The 3.2 release was the first to include the patch and it solved all the tearing issues I had.

Indeed the sandy bridge support really improved over the course of the past year and unless you have a good reason to stick with the 11.10 stock kernel you should at least try an upgrade.

share|improve this answer
    
Thanks, I'll try this ! –  Hendy Irawan Jan 29 '12 at 6:11

Did some test here and I thinks I find out the origin of the issue (or workarround)

Basically if you:
- disable composite ( sorry till now I cannot find a better solution )
AND
- [VLC] deselect this option: Video -> Display -> Accelerated video output (Overlay)
OR
- [VLC] select this video output: Video -> Output -> OpenGL GLX

You will not have any Tearing

share|improve this answer
    
Totem works fine for me anyway –  Postadelmaga Jan 26 '13 at 17:15

Place the following in to /etc/environment and reboot:

CLUTTER_PAINT=disable-clipped-redraws:disable-culling

Reference, and other useful info: https://bbs.archlinux.org/viewtopic.php?pid=1018579#p1018579

share|improve this answer
    
Good point, thanks. Answer updated –  benwh Jan 12 '12 at 22:51

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.